summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2023-03-23 10:44:57 +0100
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2023-03-26 16:58:13 +0200
commitceeeb5365de0106919857fbf1cead741b0735cfe (patch)
treee0253bec017dcfada5a269e2e2266e3f830aefe8
parentac65459d2eb9a2d8a5130b53d506b7121469b7a3 (diff)
gnu: soapysdrplay3: Update to 0.4.1-1.9e5c80c.
* nongnu/packages/radio.scm (soapysdrplay3): Update to 0.4.1-1.9e5c80c. Signed-off-by: Jonathan Brielmaier <jonathan.brielmaier@web.de>
-rw-r--r--nongnu/packages/radio.scm44
1 files changed, 23 insertions, 21 deletions
diff --git a/nongnu/packages/radio.scm b/nongnu/packages/radio.scm
index 373d0eb..a7ed2c3 100644
--- a/nongnu/packages/radio.scm
+++ b/nongnu/packages/radio.scm
@@ -85,25 +85,27 @@ package. E.g.: @code{(udev-rules-service 'sdrplay sdrplay)}")
"/license.txt")))))
(define-public soapysdrplay3
- (package
- (name "soapysdrplay3")
- (version "0.4.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/pothosware/SoapySDRPlay3")
- (commit (string-append "soapy-sdrplay3-" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0kp5gz03c29kxclaqijpyqknaijlbldrhy04mn98vnli9g1h1isq"))))
- (build-system cmake-build-system)
- (inputs
- (list sdrplay soapysdr))
- (arguments
- `(#:tests? #f)) ; No test suite
- (home-page "https://github.com/pothosware/SoapySDRPlay3/wiki")
- (synopsis "SoapySDR SDRplay module")
- (description "This package provides SDRplay devices support to the
+ (let ((commit "9e5c80c45454db56b8b10bb997369f37e750631b")
+ (revision "1"))
+ (package
+ (name "soapysdrplay3")
+ (version (git-version "0.4.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pothosware/SoapySDRPlay3")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1sl3i1id0fily7qfm0yihxsaqy4f4gr85vl5ip05azhhbrnmnayx"))))
+ (build-system cmake-build-system)
+ (inputs
+ (list sdrplay soapysdr))
+ (arguments
+ `(#:tests? #f)) ; No test suite
+ (home-page "https://github.com/pothosware/SoapySDRPlay3/wiki")
+ (synopsis "SoapySDR SDRplay module")
+ (description "This package provides SDRplay devices support to the
SoapySDR library.")
- (license expat)))
+ (license expat))))