summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2020-01-12 20:15:48 +0100
committerTimotej Lazar <timotej.lazar@araneo.si>2020-01-12 22:16:57 +0100
commit4782afc06e9a0b866490c459e6258605a20653f7 (patch)
tree9c0a31eeba9530b482a6ca76a89b8504d73798e7
parente90b62a58ac5a6d17f3e7d447187c4cbccdee2e2 (diff)
gnu: nvidia-cg-toolkit: Fix a non-exhaustive match.
* nongnu/packages/game-development.scm (nvidia-cg-toolkit): Replace a non-exhaustive match with string=? to fix evaluation on unsupported platforms.
-rw-r--r--nongnu/packages/game-development.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/nongnu/packages/game-development.scm b/nongnu/packages/game-development.scm
index 5888d13..f118944 100644
--- a/nongnu/packages/game-development.scm
+++ b/nongnu/packages/game-development.scm
@@ -53,10 +53,8 @@
(base32 "0y4qms4lm9xiix93g45337rx5nrp0y3gb0x0avyv7l9qrkk03zz8"))))
(define (lib)
- (match (or (%current-target-system)
- (%current-system))
- ("x86_64-linux" "lib64")
- ("i686-linux" "lib")))
+ (if (string=? (or (%current-target-system) (%current-system)) "x86_64-linux")
+ "lib64" "lib"))
(define-public nvidia-cg-toolkit
(package