summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Brielmaier <jonathan.brielmaier@web.de>2021-08-10 22:57:41 +0200
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2021-08-10 22:57:41 +0200
commit07ed99804675b253293847951a13aaf50b50c438 (patch)
tree7e26a2e7a63000ab24a9659cca9b1a8c2611238c
parentf69a09d7c52c8ab01069272bbc11ce517f434ced (diff)
nongnu: firefox: Update to 91.0.
* nongnu/packages/mozilla.scm (firefox): Update to 91.0. [inputs]: Use icu4c-69 as required. [native-inputs]: Use Rust 1.51 as required.
-rw-r--r--nongnu/packages/mozilla.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/nongnu/packages/mozilla.scm b/nongnu/packages/mozilla.scm
index 30901a3..115f970 100644
--- a/nongnu/packages/mozilla.scm
+++ b/nongnu/packages/mozilla.scm
@@ -83,19 +83,19 @@
;; Update this id with every firefox update to it's release date.
;; It's used for cache validation and therefor can lead to strange bugs.
-(define %firefox-build-id "20210722000000")
+(define %firefox-build-id "20210810000000")
(define-public firefox
(package
(name "firefox")
- (version "90.0.2")
+ (version "91.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://archive.mozilla.org/pub/firefox/releases/"
version "/source/firefox-" version ".source.tar.xz"))
(sha256
- (base32 "0ngzqd0cijxibcspmx1k2c5gylccl3vzxcx6vbjmkgd746y5vi1m"))))
+ (base32 "00br0x68jxwkwc86v74ymjjd3vyidfrv0sjf1lw6hzxpi9w1yk9a"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -350,7 +350,7 @@
("gtk+" ,gtk+)
("gtk+-2" ,gtk+-2)
("hunspell" ,hunspell)
- ("icu4c" ,icu4c-67)
+ ("icu4c" ,icu4c-69)
("jemalloc" ,jemalloc)
("libcanberra" ,libcanberra)
("libevent" ,libevent)
@@ -380,7 +380,7 @@
("zlib" ,zlib)))
(native-inputs
`(("autoconf" ,autoconf-2.13)
- ("cargo" ,rust-1.47 "cargo")
+ ("cargo" ,rust-1.51 "cargo")
("clang" ,clang-10)
("llvm" ,llvm-10)
("m4" ,m4)
@@ -390,7 +390,7 @@
("pkg-config" ,pkg-config)
("python" ,python)
("python2" ,python-2.7)
- ("rust" ,rust-1.47)
+ ("rust" ,rust-1.51)
("rust-cbindgen" ,rust-cbindgen-0.19)
("which" ,which)
("yasm" ,yasm)))