summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Brielmaier <jonathan.brielmaier@web.de>2021-07-14 19:06:28 +0200
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2021-07-14 19:06:28 +0200
commit4cfb6936a1e89950994822ba43643739e7b1f068 (patch)
tree93e733062a67b259efec12e82df5c6f52e01ce79
parent168f2fcfb2bb78565175807686c08794237a6e42 (diff)
nongnu: firefox: Update to 90.0 [security fixes].
Fixes CVE-2021-29970, CVE-2021-30547, CVE-2021-29972, CVE-2021-29974, CVE-2021-29975, CVE-2021-29976 and CVE-2021-29977. * nongnu/packages/mozilla.scm (firefox): Update to 90.0.
-rw-r--r--nongnu/packages/mozilla.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/nongnu/packages/mozilla.scm b/nongnu/packages/mozilla.scm
index 2d7c103..9f0402e 100644
--- a/nongnu/packages/mozilla.scm
+++ b/nongnu/packages/mozilla.scm
@@ -83,19 +83,19 @@
;; Update this id with every firefox update to it's release date.
;; It's used for cache validation and therefor can lead to strange bugs.
-(define %firefox-build-id "20210623000000")
+(define %firefox-build-id "20210713000000")
(define-public firefox
(package
(name "firefox")
- (version "89.0.2")
+ (version "90.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://archive.mozilla.org/pub/firefox/releases/"
version "/source/firefox-" version ".source.tar.xz"))
(sha256
- (base32 "152lmhh6ayvbxg6ml81qbiv0rswx6ln1mxqnmm9dysz3qn1za99j"))))
+ (base32 "12ymc3m75cs4v3dlbfyhiala9mkz9cs5pja1bdzns336szkl7aa3"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags