summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2021-07-25 18:07:31 +0200
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2021-08-15 14:23:51 +0200
commit967838c40d9d4a04254b9e496b356a8a7b5015ae (patch)
tree2cb1f9c17dff0ad4b83bc6db97fc616d8f576556
parent54c0298b9e756745a3b6427781ee2e0229303662 (diff)
nongnu: Add raspberrypi-firmware.
* nongnu/packages/linux.scm (raspberrypi-firmware): New variable. Signed-off-by: Jonathan Brielmaier <jonathan.brielmaier@web.de>
-rw-r--r--nongnu/packages/linux.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/nongnu/packages/linux.scm b/nongnu/packages/linux.scm
index fd17630..4b42b1e 100644
--- a/nongnu/packages/linux.scm
+++ b/nongnu/packages/linux.scm
@@ -178,6 +178,32 @@ graphics cards can be run with the free Mesa, some cards require a nonfree
kernel module to run properly and support features like hibernation and
advanced 3D.")))
+(define-public raspberrypi-firmware
+(package
+ (name "raspberrypi-firmware")
+ (version "1.20210527")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/raspberrypi/firmware")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "08lgg90k6lhqm3ccg7db0lrrng0pgf63dvbrxpfpwm1pswrc5vf5"))))
+ (build-system copy-build-system)
+ (synopsis "Firmware for the Raspberry Pi boards")
+ (description "Pre-compiled binaries of the current Raspberry Pi kernel
+and modules, userspace libraries, and bootloader/GPU firmware.")
+ (home-page "https://github.com/raspberrypi/firmware")
+ (supported-systems '("armhf-linux" "aarch64-linux"))
+ (license
+ (list gpl2
+ (nonfree
+ (string-append "file://boot/LICENCE.broadcom"))
+ (nonfree
+ (string-append "file://opt/vc/LICENCE"))))))
+
(define-public atheros-firmware
(package
(inherit linux-firmware)