summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorison <ison@airmail.cc>2021-10-28 12:38:51 -0600
committerison <ison@airmail.cc>2021-10-28 12:38:51 -0600
commitaf0398e85357b11606ae24d8e39b2a70ca38ad22 (patch)
tree640271ac774b3d33485809dace2d1cb1a2fc1302
parent079084f6415af2bf4a32b8f3611470a488664f12 (diff)
nongnu: steam: Use guix shell.
* nongnu/packages/steam-client.scm (make-container-wrapper): Replace guix environment with new guix shell command.
-rw-r--r--nongnu/packages/steam-client.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/nongnu/packages/steam-client.scm b/nongnu/packages/steam-client.scm
index 7e91af8..05e0192 100644
--- a/nongnu/packages/steam-client.scm
+++ b/nongnu/packages/steam-client.scm
@@ -31,7 +31,7 @@
;;; A container wrapper creates the following store items:
;;; * Main container package [nonguix-container->package] (basically a dummy
;;; package with symlink to wrapper script)
-;;; - Wrapper script [make-container-wrapper] (runs "guix environment")
+;;; - Wrapper script [make-container-wrapper] (runs "guix shell")
;;; References:
;;; -> manifest.scm [make-container-manifest] (used by wrapper to guarantee
;;; exact store items)
@@ -362,8 +362,8 @@ in a sandboxed FHS environment."
"--start"
"--exit-idle-time=60")
(apply invoke
- `("guix" "environment"
- "--ad-hoc" "--container" "--no-cwd" "--network"
+ `("guix" "shell"
+ "--container" "--no-cwd" "--network"
,@(map preserve-var preserved-env)
,@(map add-path expose)
,@(map (lambda (item)