summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-10-22 15:52:08 -0400
committerJohn Kehayias <john.kehayias@protonmail.com>2023-10-22 15:52:08 -0400
commit6ac2849b56c87c318149d496d0d353ff590a01a9 (patch)
tree49c2dd18de71724c26890fb3ae08c71017cb13dc
parent46c8b08cd6adf442dec43dc7f9a1033842e49bbc (diff)
[DRAFT] nongnu: steam: Use mesa-next.
* nongnu/packages/steam-client.scm (steam-client-libs): Replace mesa-fixed with mesa-next.
-rw-r--r--nongnu/packages/steam-client.scm4
1 files changed, 1 insertions, 3 deletions
diff --git a/nongnu/packages/steam-client.scm b/nongnu/packages/steam-client.scm
index befcd0b..aa5a8c8 100644
--- a/nongnu/packages/steam-client.scm
+++ b/nongnu/packages/steam-client.scm
@@ -180,9 +180,7 @@
("libvdpau-va-gl" ,libvdpau-va-gl) ; Additional VDPAU support.
("llvm" ,llvm-for-mesa) ; Required for mesa.
("lsof" ,lsof) ; Required for some friend's list actions.
- ;; TODO: Set back to mesa once libx11 is ungrafted upstream or once
- ;; <https://issues.guix.gnu.org/53406> is fixed.
- ("mesa" ,mesa-fixed) ; Required for steam startup.
+ ("mesa" ,mesa-next) ; Required for steam startup.
("nss-certs" ,nss-certs) ; Required for steam login.
("pciutils" ,pciutils) ; Tries to run lspci at steam startup.
("procps" ,procps)