summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2023-05-19 22:10:24 +0200
committerJohn Kehayias <john.kehayias@protonmail.com>2023-09-07 17:07:28 -0400
commita922d5be64de13d332b105e50a13d932423035f8 (patch)
tree13564faeaa7afecb987ab17f5fed31e0e6665675
parent5155d7ec303dde4f75e0ca1a66e926225e450255 (diff)
nongnu: Add helm.
* nongnu/packages/k8s.scm (helm): New variable. Signed-off-by: John Kehayias <john.kehayias@protonmail.com>
-rw-r--r--nongnu/packages/k8s.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/nongnu/packages/k8s.scm b/nongnu/packages/k8s.scm
index 7f42f5d..8c83eb9 100644
--- a/nongnu/packages/k8s.scm
+++ b/nongnu/packages/k8s.scm
@@ -144,3 +144,36 @@ view logs.")
"Kompose is a conversion tool for Docker Compose to container orchestrators
such as Kubernetes (or OpenShift).")
(license license:expat)))
+
+(define-public helm
+ (package
+ (name "helm")
+ (version "3.12.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://get.helm.sh/helm-v" version "-linux-amd64.tar.gz"))
+ (sha256
+ (base32
+ "1d99c506shnz5cr9xhkrla5r82nan7v3hz631jqflicd376i68qv"))))
+ (build-system copy-build-system)
+ (arguments
+ (list
+ #:substitutable? #f
+ #:install-plan
+ #~'(("linux-amd64/helm" "bin/"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'unpack
+ (lambda _
+ (invoke "tar" "-xvf" #$source)))
+ (add-before 'install 'chmod
+ (lambda _
+ (chmod "linux-amd64/helm" #o555))))))
+ (home-page "https://helm.sh")
+ (supported-systems '("x86_64-linux"))
+ (synopsis "The package manager for Kubernetes")
+ (description
+ "Helm helps you manage Kubernetes applications - Helm Charts help you
+define, install, and upgrade Kubernetes applications.")
+ (license license:asl2.0)))