summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Griffin <a@ajgrf.com>2020-01-05 11:50:23 -0600
committerAlex Griffin <a@ajgrf.com>2020-01-05 11:50:23 -0600
commit1da9083f981582eb709575c933785bd47ca52877 (patch)
tree86ac29f5a8abb96ed0ef442ba7ad1fb464aeaa24
parentc249eba4628c307331e0cde7563d8bacd597b4ab (diff)
nongnu: linux-firmware: Use gnu-build-system.
* nongnu/packages/linux.scm (linux-firmware): Use gnu-build-system.
-rw-r--r--nongnu/packages/linux.scm25
1 files changed, 11 insertions, 14 deletions
diff --git a/nongnu/packages/linux.scm b/nongnu/packages/linux.scm
index 42ab3a7..17c8edd 100644
--- a/nongnu/packages/linux.scm
+++ b/nongnu/packages/linux.scm
@@ -25,6 +25,7 @@
#:use-module (guix utils)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix build-system gnu)
#:use-module (guix build-system linux-module)
#:use-module (guix build-system trivial)
#:use-module (ice-9 match)
@@ -84,21 +85,17 @@ on hardware which requires nonfree software to function.")))
(sha256
(base32
"024napabn3zwl8gr50w9cp4gdxhch8pkl2qx814c93ydkfj81znd"))))
- (build-system trivial-build-system)
+ (build-system gnu-build-system)
(arguments
- `(#:modules ((guix build utils))
- #:builder (begin
- (use-modules (guix build utils))
- (let ((source (assoc-ref %build-inputs "source"))
- (destination (string-append %output "/lib/firmware"))
- (gzip (assoc-ref %build-inputs "gzip"))
- (tar (assoc-ref %build-inputs "tar")))
- (set-path-environment-variable "PATH" '("bin")
- (list tar gzip))
- (invoke "tar" "--strip-components=1" "-xvf" source)
- (mkdir-p destination)
- (copy-recursively "." destination #:follow-symlinks? #t)
- #t))))
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (invoke "make" "install"
+ (string-append "DESTDIR=" out)))))
+ (delete 'validate-runpath))))
(native-inputs
`(("gzip" ,gzip)
("tar" ,tar)))