summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Griffin <a@ajgrf.com>2020-01-05 15:30:35 -0600
committerAlex Griffin <a@ajgrf.com>2020-01-05 15:30:35 -0600
commit6bffec90c0ca1c043accc09b2d31cc77862a7f25 (patch)
tree9f5f0ffefff3c9af2f42c92e514a2eae579f3394
parent7032ec3cd89ed4a36bee7cf62a978522a2912431 (diff)
nongnu: atheros-firmware: Update license field.
* nongnu/packages/linux.scm (atheros-firmware)[license]: Add missing licenses.
-rw-r--r--nongnu/packages/linux.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/nongnu/packages/linux.scm b/nongnu/packages/linux.scm
index 8ca5b7c..cfb1027 100644
--- a/nongnu/packages/linux.scm
+++ b/nongnu/packages/linux.scm
@@ -21,6 +21,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages compression)
#:use-module (gnu packages linux)
+ #:use-module (guix licenses)
#:use-module (guix packages)
#:use-module (guix utils)
#:use-module (guix download)
@@ -315,10 +316,18 @@ WLAN.TF.2.1-00021-QCARMSWP-1 (ath10k/QCA9377/hw1.0/firmware-6.bin)
(string-append
"https://git.kernel.org/pub/scm/linux/kernel/git/firmware"
"/linux-firmware.git/plain/LICENCE.atheros_firmware"))
+ (non-copyleft
+ (string-append
+ "https://git.kernel.org/pub/scm/linux/kernel/git/firmware"
+ "/linux-firmware.git/plain/LICENCE.open-ath9k-htc-firmware"))
+ (nonfree
+ (string-append
+ "https://git.kernel.org/pub/scm/linux/kernel/git/firmware"
+ "/linux-firmware.git/plain/LICENCE.QualcommAtheros_ar3k"))
(nonfree
(string-append
"https://git.kernel.org/pub/scm/linux/kernel/git/firmware"
- "/linux-firmware.git/plain/LICENSE.QualcommAtheros_ar3k"))))))
+ "/linux-firmware.git/plain/LICENSE.QualcommAtheros_ath10k"))))))
(define-public ath3k-firmware
(deprecated-package "ath3k-firmware" atheros-firmware))