summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2022-11-25 17:06:43 -0500
committerJohn Kehayias <john.kehayias@protonmail.com>2022-11-25 17:06:43 -0500
commit2e166ea5d25f2d8dbcf10c87b7d4aa74f3274754 (patch)
tree8cf78044498598d0607c72365dc1a6db58625a8b
parente026dba1dad924aa09da8a28caa343a8ace3f6c7 (diff)
nongnu: corrupt-linux: Add infodocs patch.
Fixes #217. Builds of the linux kernel were failing without a recently added patch from Guix to add an infodocs target for make. See commit 82c43b276dd5e60c81ad2c040a9d945befc4bc88. We now use this patch for applicable kernels (version 5.10 or greater) so the 'build-doc' phase succeeds. * nongnu/package/linux.scm (corrupt-linux)[source]: Add patches with "linux-libre-infodocs-target.patch" depending on version with the procedure doc-supported? from (gnu packages linux).
-rw-r--r--nongnu/packages/linux.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/nongnu/packages/linux.scm b/nongnu/packages/linux.scm
index 8c4e2fe..380dc1c 100644
--- a/nongnu/packages/linux.scm
+++ b/nongnu/packages/linux.scm
@@ -63,7 +63,14 @@
(source (origin
(method url-fetch)
(uri (linux-urls version))
- (sha256 (base32 hash))))
+ (sha256 (base32 hash))
+ ;; By default the linux-libre package will "make infodocs" for
+ ;; supported kernels (version > 5.10) which needs the following
+ ;; patch. Include the patch if it applies rather than disabling
+ ;; the associated "build-doc" phase.
+ (patches (if ((@@ (gnu packages linux) doc-supported?) version)
+ (search-patches "linux-libre-infodocs-target.patch")
+ '()))))
(home-page "https://www.kernel.org/")
(synopsis "Linux kernel with nonfree binary blobs included")
(description