summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Brielmaier <jonathan.brielmaier@web.de>2023-06-07 11:21:55 +0200
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2023-06-07 11:21:55 +0200
commit6a03e22b7ea4a8c9435501947f8628cdcf6ed63d (patch)
treea8c67520253eb521b007eca8bb308c95f0a1d77b
parent27a471f56b93e79403d52888d6a485149f781b56 (diff)
nongnu: firefox: Update to 114.0 [security fixes].
Fixes CVE-2023-34414, CVE-2023-34415, CVE-2023-34416 and CVE-2023-34417. * nongnu/packages/mozilla.scm (firefox): Update to 114.0.
-rw-r--r--nongnu/packages/mozilla.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/nongnu/packages/mozilla.scm b/nongnu/packages/mozilla.scm
index 50cb26a..8fc28af 100644
--- a/nongnu/packages/mozilla.scm
+++ b/nongnu/packages/mozilla.scm
@@ -512,20 +512,20 @@ MOZ_ENABLE_WAYLAND=1 exec ~a $@\n"
;; Update this id with every firefox update to it's release date.
;; It's used for cache validation and therefor can lead to strange bugs.
-(define %firefox-build-id "20230509000000")
+(define %firefox-build-id "20230606000000")
(define-public firefox
(package
(inherit firefox-esr)
(name "firefox")
- (version "113.0")
+ (version "114.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://archive.mozilla.org/pub/firefox/releases/"
version "/source/firefox-" version ".source.tar.xz"))
(sha256
- (base32 "09r60z34clfidx7nmgsckww262n8l1z50lrlkc3n634xrd2609ks"))))
+ (base32 "1ijbbfdbxrcaa23kfqw50pa3igs75fl7p0wnwh612ligfh10afnj"))))
(arguments
(substitute-keyword-arguments (package-arguments firefox-esr)
((#:phases phases)