summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2022-11-21 14:48:33 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2022-11-21 15:04:42 +0100
commit6df7d0d4f01e9ffad901ef63b0adf112cfc6ab0f (patch)
tree2d36f8aea098a8d26f4147fb7c4f07e006f2bf69
parentf3227e33d1782508bbf530de61fa3a8bda253423 (diff)
nongnu: dxvk-next: Update to 2.0.
* nongnu/packages/wine.scm (dxvk-next): Update to 2.0. * nongnu/packages/wine.scm (dxvk-1.10): New variable.
-rw-r--r--nongnu/packages/wine.scm20
1 files changed, 18 insertions, 2 deletions
diff --git a/nongnu/packages/wine.scm b/nongnu/packages/wine.scm
index ff15e23..7d63a8c 100644
--- a/nongnu/packages/wine.scm
+++ b/nongnu/packages/wine.scm
@@ -157,7 +157,7 @@ Use @command{setup_dxvk} to install the required libraries to a Wine prefix.")
(define-public dxvk-next
(package
(name "dxvk")
- (version "1.10.1")
+ (version "2.0")
(home-page "https://github.com/doitsujin/dxvk/")
(source (origin
(method url-fetch)
@@ -166,7 +166,7 @@ Use @command{setup_dxvk} to install the required libraries to a Wine prefix.")
version "/dxvk-" version ".tar.gz") )
(sha256
(base32
- "1ah7nci49ipaj7z7zac4dqbrxq1ic3zyky42kkid8wqarf198d6w"))))
+ "0xr4lq4zdmqwxh5x19am2y4lvy6q6s6bl1nfr4ixfgy2l2sghliq"))))
(build-system copy-build-system)
(arguments
`(#:install-plan
@@ -211,3 +211,19 @@ allows running complex 3D applications with high performance using Wine.
Use @command{setup_dxvk} to install the required libraries to a Wine prefix.")
(supported-systems '("i686-linux" "x86_64-linux"))
(license license:zlib)))
+
+;; Keep 1.10 since it's backward-compatible with older hardware unlike 2.*
+;; See https://github.com/doitsujin/dxvk/releases/tag/v2.0
+(define-public dxvk-1.10
+ (package
+ (inherit dxvk)
+ (version "1.10.1")
+ (home-page "https://github.com/doitsujin/dxvk/")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/doitsujin/dxvk/releases/download/v"
+ version "/dxvk-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1ah7nci49ipaj7z7zac4dqbrxq1ic3zyky42kkid8wqarf198d6w"))))))