summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Brielmaier <jonathan.brielmaier@web.de>2022-05-05 19:05:11 +0200
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2022-05-05 19:05:11 +0200
commit8f8bdc8ec6e03c6453e2e4c43a8b5c0f37a0d401 (patch)
treecc678a1f46e688a064f57d5dbd5305d0cc3e30ae
parent176f36df21ece6bcd3838c83b7326cc680b58c80 (diff)
nongnu: firefox Update to 100.0 [security fixes].
Fixes CVE-2022-29909, CVE-2022-29910, CVE-2022-29911, CVE-2022-29914, CVE-2022-29915, CVE-2022-29916, CVE-2022-29917 and CVE-2022-29918. * nongnu/packages/mozilla.scm (firefox): Update to 100.0.
-rw-r--r--nongnu/packages/mozilla.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/nongnu/packages/mozilla.scm b/nongnu/packages/mozilla.scm
index 5e5e4a4..11ad993 100644
--- a/nongnu/packages/mozilla.scm
+++ b/nongnu/packages/mozilla.scm
@@ -86,19 +86,19 @@
;; Update this id with every firefox update to it's release date.
;; It's used for cache validation and therefor can lead to strange bugs.
-(define %firefox-build-id "20220412000000")
+(define %firefox-build-id "20220503000000")
(define-public firefox
(package
(name "firefox")
- (version "99.0.1")
+ (version "100.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://archive.mozilla.org/pub/firefox/releases/"
version "/source/firefox-" version ".source.tar.xz"))
(sha256
- (base32 "02z0fa55nmnl90hiyqq0b65r3mg09c339l5jidr8ln4rrrwj5lkn"))))
+ (base32 "0zsy5nxkq44k23bcgswfl4rxaib0k52d2lp6lim8hw7vw320qk36"))))
(build-system gnu-build-system)
(arguments
(list