summaryrefslogtreecommitdiff
path: root/nongnu/packages/clojure.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-01-03 11:16:54 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2020-01-03 11:16:54 +0100
commit417b416efcffd8b81d397bac15d12860e7c7f974 (patch)
tree343503a5d393308aecd5da6d11ccea8520246fcf /nongnu/packages/clojure.scm
parent0c7cef591b9ea2d7b5227ab5548c8c56bff79915 (diff)
nongnu: Add leiningen.
* nongnu/packages/clojure.scm (leiningen): New variable.
Diffstat (limited to 'nongnu/packages/clojure.scm')
-rw-r--r--nongnu/packages/clojure.scm56
1 files changed, 56 insertions, 0 deletions
diff --git a/nongnu/packages/clojure.scm b/nongnu/packages/clojure.scm
new file mode 100644
index 0000000..2b4c57c
--- /dev/null
+++ b/nongnu/packages/clojure.scm
@@ -0,0 +1,56 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
+;;;
+;;; This file is not part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (nongnu packages clojure)
+ #:use-module (guix packages)
+ #:use-module (guix build-system ant)
+ #:use-module (guix download)
+ #:use-module ((guix licenses) #:prefix license:))
+
+(define-public leiningen
+ (package
+ (name "leiningen")
+ (version "2.9.1")
+ (source (origin
+ (method url-fetch/tarbomb)
+ (uri (string-append
+ "https://github.com/technomancy/leiningen/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version))
+ (sha256
+ (base32
+ "0acbmgs9sq6rc24b0ly2345pvyfky03s3gzmzvi98vsp0ys3khm4"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (delete 'check)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (install-file (string-append
+ "leiningen-" ,version "/bin/lein")
+ (string-append
+ (assoc-ref outputs "out") "/bin")))))))
+ (home-page "https://leiningen.org")
+ (synopsis "Automating Clojure projects without setting your hair on fire")
+ (description "Leiningen is an easy way to use Clojure. With a focus
+on project automation and declarative configuration, it gets out of your way
+and lets you focus on your code.")
+ (license license:epl1.0)))