summaryrefslogtreecommitdiff
path: root/nongnu/packages/coq.scm
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2020-04-11 13:16:59 +0200
committerTimotej Lazar <timotej.lazar@araneo.si>2020-04-11 14:11:11 +0200
commit1892d626dd36d6b6d8553d03050afc7022e86c73 (patch)
tree8ecb929c677b640b803af62f6c2bfe02a83dd18f /nongnu/packages/coq.scm
parent22450afd709b3c23e0082592f9981ed3e8c05aad (diff)
nongnu: compcert: Fix a non-exhaustive match.
* nongnu/packages/coq.scm (compcert)[arguments]: Add default case to match so that it can be evaluated on all systems. [supported-systems]: Remove unsupported mips64el-linux.
Diffstat (limited to 'nongnu/packages/coq.scm')
-rw-r--r--nongnu/packages/coq.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/nongnu/packages/coq.scm b/nongnu/packages/coq.scm
index e564dc0..de067ab 100644
--- a/nongnu/packages/coq.scm
+++ b/nongnu/packages/coq.scm
@@ -43,9 +43,9 @@
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
(let ((system ,(match (or (%current-target-system) (%current-system))
- ("x86_64-linux" "x86_64-linux")
+ ("armhf-linux" "arm-linux")
("i686-linux" "x86_32-linux")
- ("armhf-linux" "arm-linux"))))
+ (s s))))
(format #t "Building for ~a~%" system)
(invoke "./configure" system "-prefix"
(assoc-ref outputs "out")))
@@ -62,6 +62,8 @@
(find-files "." ".*.vo$"))
#t)))
#:tests? #f))
+ ;; MIPS is not supported.
+ (supported-systems (delete "mips64el-linux" %supported-systems))
(native-inputs
`(("ocaml" ,ocaml)
("ocaml-findlib" ,ocaml-findlib); for menhir --suggest-menhirlib