summaryrefslogtreecommitdiff
path: root/nongnu/packages/emacs.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-06-06 11:00:34 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2019-06-06 11:00:34 +0200
commit141dc477bc76489f643f3990b7b96a9134c36577 (patch)
tree4c2a708ac08f456c57040cf3fdbe0e0df7b1779b /nongnu/packages/emacs.scm
parent8256ea3fb794d44f1ec429e0f36f71a7e9b938da (diff)
nongnu: Add clhs.
* nongnu/packages/emacs.scm: New file. (clhs): New variable.
Diffstat (limited to 'nongnu/packages/emacs.scm')
-rw-r--r--nongnu/packages/emacs.scm69
1 files changed, 69 insertions, 0 deletions
diff --git a/nongnu/packages/emacs.scm b/nongnu/packages/emacs.scm
new file mode 100644
index 0000000..dab1065
--- /dev/null
+++ b/nongnu/packages/emacs.scm
@@ -0,0 +1,69 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
+;;;
+;;; This file is not part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (nongnu packages emacs)
+ #:use-module (guix packages)
+ #:use-module (guix build-system emacs)
+ #:use-module (guix download)
+ #:use-module (nonguix licenses))
+
+(define-public clhs
+ (package
+ (name "clhs")
+ (version "0.6.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://beta.quicklisp.org/archive/clhs/2015-04-07/clhs-"
+ version
+ ".tgz"))
+ (sha256
+ (base32
+ "1cn5bfrcawrbc8s1wb07lpr6xv8758l1n5pgkyhamagmi1r0x128"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'replace-loader
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (delete-file "clhs-use-local.el")
+ (with-output-to-file "clhs.el"
+ (lambda ()
+ (display
+ (string-append
+ "(defun clhs-setup ()
+ (setq common-lisp-hyperspec-root
+ \"file://"
+ (string-append (assoc-ref outputs "out")
+ "/HyperSpec-7-0/HyperSpec/")
+ "\"))\n"
+ "(provide 'clhs)"))))))
+ (add-after 'install 'install-doc
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (copy-recursively "HyperSpec-7-0"
+ (string-append (assoc-ref outputs "out")
+ "/HyperSpec-7-0")))))))
+ (home-page "http://quickdocs.org/clhs/")
+ (synopsis "Offline Common Lisp HyperSpec")
+ (description
+ "This package bundles the full Common Lisp HyperSpec ready for offline browsing.
+An Emacs package is provided for easy access. Load it with:
+
+ (require 'clhs)
+ (clhs-setup)")
+ (license (nonfree "http://quickdocs.org/clhs/"))))