summaryrefslogtreecommitdiff
path: root/nongnu/packages/game-development.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-05-04 12:23:51 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2020-05-04 12:23:51 +0200
commitda984ee8ef6f9c15232a6340fb27c76a2c4647a4 (patch)
tree921d2721dda5ccf6ee3d5033cdc7e9e33cb60a62 /nongnu/packages/game-development.scm
parent2f9c97e0b0e61b8061302d1c5aa750c2bec3edcf (diff)
nongnu: Move fury from the duke-nukem-3d channel to Nonguix.
* nongnu/packages/game-development.scm (fury): New variable.
Diffstat (limited to 'nongnu/packages/game-development.scm')
-rw-r--r--nongnu/packages/game-development.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/nongnu/packages/game-development.scm b/nongnu/packages/game-development.scm
index 025dac8..95facd2 100644
--- a/nongnu/packages/game-development.scm
+++ b/nongnu/packages/game-development.scm
@@ -24,6 +24,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix utils)
#:use-module (gnu packages audio)
#:use-module (gnu packages base)
#:use-module (gnu packages gcc)
@@ -283,3 +284,27 @@ with game files or or put @file{.grp} game files manually in
(home-page "https://eduke32.com/")
(license (license:nonfree
"https://eduke32.com/buildlic.txt")))))
+
+(define-public fury
+ (package
+ (inherit eduke32)
+ (name "fury")
+ (arguments
+ (substitute-keyword-arguments (package-arguments eduke32)
+ ((#:make-flags flags ''()) `(cons* "FURY=1" ,flags))
+ ((#:phases phases '%standard-phases)
+ `(modify-phases ,phases
+ (replace 'install
+ (lambda _
+ (let* ((out (assoc-ref %outputs "out")))
+ (install-file "fury" (string-append out "/bin"))
+ (install-file "mapster32" (string-append out "/bin"))
+ (install-file "package/common/buildlic.txt"
+ (string-append out "/share/licenses")))
+ #t))))))
+ (synopsis "Game engine for the first-person shooter Ion Fury")
+ (description
+ (string-append
+ "This is the @code{eduke32} engine built with support for the Ion Fury
+game. Game data is not provided. Run @command{fury} with the option
+@option{-j} to specify the directory containing @file{fury.grp}."))))