summaryrefslogtreecommitdiff
path: root/nongnu/packages/linux.scm
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2019-08-27 02:24:11 +0200
committerTimotej Lazar <timotej.lazar@araneo.si>2019-09-05 19:22:45 +0200
commitc60b3b003c446c5bb56548f8519675c2c3cfc6c4 (patch)
tree331ddbe22032558591bc1b79e0e3609c8d5251a4 /nongnu/packages/linux.scm
parent449038367a46612a79fa7ee5f9b529376e9c25c1 (diff)
gnu: Add intel-microcode.
* nongnu/packages/linux.scm (intel-microcode): New variable.
Diffstat (limited to 'nongnu/packages/linux.scm')
-rw-r--r--nongnu/packages/linux.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/nongnu/packages/linux.scm b/nongnu/packages/linux.scm
index d7db0da..0048c0b 100644
--- a/nongnu/packages/linux.scm
+++ b/nongnu/packages/linux.scm
@@ -1,6 +1,7 @@
;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2019 Timotej Lazar <timotej.lazar@araneo.si>
;;;
;;; This program is free software: you can redistribute it and/or modify
;;; it under the terms of the GNU General Public License as published by
@@ -507,3 +508,44 @@ firmware for the following chips:
(string-append
"https://git.kernel.org/pub/scm/linux/kernel/git/firmware"
"/linux-firmware.git/plain/LICENCE.rtlwifi_firmware.txt")))))
+
+(define-public intel-microcode
+ (package
+ (name "intel-microcode")
+ (version "20190618")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append
+ "https://github.com/intel/"
+ "Intel-Linux-Processor-Microcode-Data-Files.git"))
+ (commit (string-append "microcode-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0fdhrpxvsq0rm5mzj82gvmfb3lm7mhc9hwvimv7dl1jaidbp6lvs"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let* ((source (assoc-ref %build-inputs "source"))
+ (fw-dir (string-append %output "/lib/firmware"))
+ (bin-dir (string-append fw-dir "/intel-ucode")))
+ (mkdir-p bin-dir)
+ (copy-recursively (string-append source "/intel-ucode") bin-dir)
+ (copy-file
+ (string-append source "/license")
+ (string-append fw-dir "/LICENSE.intel-ucode"))
+ #t))))
+ (home-page
+ "https://github.com/intel/Intel-Linux-Processor-Microcode-Data-Files")
+ (synopsis "Processor microcode firmware for Intel CPUs")
+ (description "Updated system processor microcode for Intel i686 and Intel
+x86-64 processors. Intel releases microcode updates to correct processor
+behavior as documented in the respective processor specification updates. The
+@code{iucode-tool} package can be used to determine the appropriate file for
+your CPU.")
+ (license (nonfree "file://license"))))