summaryrefslogtreecommitdiff
path: root/nongnu/packages/patches/broadcom-sta-linux-4.11.patch
diff options
context:
space:
mode:
authorAlex Griffin <a@ajgrf.com>2019-05-30 03:48:38 -0500
committerAlex Griffin <a@ajgrf.com>2019-05-30 05:43:32 -0500
commit5b9fbf947411587f9bb54f123fa1501b7fc60b7a (patch)
treec72b60915b2ca11dd3a20311ffd9a72f2a0eae8c /nongnu/packages/patches/broadcom-sta-linux-4.11.patch
parent7513783896aaa99500bd24d7ad9987892450f9c7 (diff)
nongnu: Add broadcom-sta.
* nongnu/packages/linux.scm (broadcom-sta): New variable. * nongnu/packages/patches/broadcom-sta-debian-fix-kernel-warnings.patch: New file. * nongnu/packages/patches/broadcom-sta-fix_mac_profile_discrepancy.patch: New file. * nongnu/packages/patches/broadcom-sta-gcc.patch: New file. * nongnu/packages/patches/broadcom-sta-license.patch: New file. * nongnu/packages/patches/broadcom-sta-linux-4.11.patch: New file. * nongnu/packages/patches/broadcom-sta-linux-4.12.patch: New file. * nongnu/packages/patches/broadcom-sta-linux-4.15.patch: New file. * nongnu/packages/patches/broadcom-sta-linux-4.7.patch: New file. * nongnu/packages/patches/broadcom-sta-linux-4.8.patch: New file. * nongnu/packages/patches/broadcom-sta-linux-5.1.patch: New file. * nongnu/packages/patches/broadcom-sta-null-pointer-fix.patch: New file. * nongnu/packages/patches/broadcom-sta-rdtscl.patch: New file.
Diffstat (limited to 'nongnu/packages/patches/broadcom-sta-linux-4.11.patch')
-rw-r--r--nongnu/packages/patches/broadcom-sta-linux-4.11.patch52
1 files changed, 52 insertions, 0 deletions
diff --git a/nongnu/packages/patches/broadcom-sta-linux-4.11.patch b/nongnu/packages/patches/broadcom-sta-linux-4.11.patch
new file mode 100644
index 0000000..a779f8c
--- /dev/null
+++ b/nongnu/packages/patches/broadcom-sta-linux-4.11.patch
@@ -0,0 +1,52 @@
+diff --git a/src/wl/sys/wl_cfg80211_hybrid.c b/src/wl/sys/wl_cfg80211_hybrid.c
+index a9671e2..da36405 100644
+--- a/src/wl/sys/wl_cfg80211_hybrid.c
++++ b/src/wl/sys/wl_cfg80211_hybrid.c
+@@ -30,6 +30,9 @@
+ #include <linux/kthread.h>
+ #include <linux/netdevice.h>
+ #include <linux/ieee80211.h>
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 11, 0)
++#include <linux/sched/signal.h>
++#endif
+ #include <net/cfg80211.h>
+ #include <linux/nl80211.h>
+ #include <net/rtnetlink.h>
+diff --git a/src/wl/sys/wl_linux.c b/src/wl/sys/wl_linux.c
+index 489c9f5..f8278ad 100644
+--- a/src/wl/sys/wl_linux.c
++++ b/src/wl/sys/wl_linux.c
+@@ -117,6 +117,9 @@ int wl_found = 0;
+
+ typedef struct priv_link {
+ wl_if_t *wlif;
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 11, 0)
++ unsigned long last_rx;
++#endif
+ } priv_link_t;
+
+ #define WL_DEV_IF(dev) ((wl_if_t*)((priv_link_t*)DEV_PRIV(dev))->wlif)
+@@ -2450,6 +2453,9 @@ wl_monitor(wl_info_t *wl, wl_rxsts_t *rxsts, void *p)
+ {
+ struct sk_buff *oskb = (struct sk_buff *)p;
+ struct sk_buff *skb;
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 11, 0)
++ priv_link_t *priv_link;
++#endif
+ uchar *pdata;
+ uint len;
+
+@@ -2916,7 +2922,13 @@ wl_monitor(wl_info_t *wl, wl_rxsts_t *rxsts, void *p)
+ if (skb == NULL) return;
+
+ skb->dev = wl->monitor_dev;
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 11, 0)
++ priv_link = MALLOC(wl->osh, sizeof(priv_link_t));
++ priv_link = netdev_priv(skb->dev);
++ priv_link->last_rx = jiffies;
++#else
+ skb->dev->last_rx = jiffies;
++#endif
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 22)
+ skb_reset_mac_header(skb);
+ #else