summaryrefslogtreecommitdiff
path: root/nongnu/packages/patches/broadcom-sta-null-pointer-fix.patch
diff options
context:
space:
mode:
authorKrzysztof Baranowski <pharcosyle@gmail.com>2023-03-20 12:04:59 -0700
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2023-04-05 20:53:03 +0200
commit76a34782395ca71b4ea85a5a7821d5f15b47299d (patch)
treecb2f501cacfafac1f6a95e388c0d2832df11be7f /nongnu/packages/patches/broadcom-sta-null-pointer-fix.patch
parent213be7ee6676fc4a3db0e3ac9ce5cd79e2ed209e (diff)
nongnu: broadcom-sta: Use Nixpkgs patch list.
Piggy-back off of the patch list in Nixpkgs instead of maintaining our own. This should make it easier to keep up to date so there's no need to advise users to stick with Linux LTS releases any longer. Though our existing patch list and Nixpkgs' differ the cumulative effect is exactly the same except for two patches we have that Nix doesn't, neither of which seem critical: - broadcom-sta-debian-fix-kernel-warnings.patch - broadcom-sta-fix_mac_profile_discrepancy.patch Closes #246 * nongnu/packages/linux.scm (broadcom-sta): Replace patches with code to fetch them from Nixpkgs. [arguments]: Replace `linux-lts` with `linux`. [description]: Remove Linux LTS recommendation. * nongnu/packages/patches/broadcom-sta-debian-fix-kernel-warnings.patch: Remove. * nongnu/packages/patches/broadcom-sta-fix_mac_profile_discrepancy.patch: Remove. * nongnu/packages/patches/broadcom-sta-gcc.patch: Remove. * nongnu/packages/patches/broadcom-sta-license.patch: Remove. * nongnu/packages/patches/broadcom-sta-linux-4.11.patch: Remove. * nongnu/packages/patches/broadcom-sta-linux-4.12.patch: Remove. * nongnu/packages/patches/broadcom-sta-linux-4.15.patch: Remove. * nongnu/packages/patches/broadcom-sta-linux-4.7.patch: Remove. * nongnu/packages/patches/broadcom-sta-linux-4.8.patch: Remove. * nongnu/packages/patches/broadcom-sta-linux-5.1.patch: Remove. * nongnu/packages/patches/broadcom-sta-linux-5.10.patch: Remove. * nongnu/packages/patches/broadcom-sta-linux-5.6.patch: Remove. * nongnu/packages/patches/broadcom-sta-linux-5.9.patch: Remove. * nongnu/packages/patches/broadcom-sta-null-pointer-fix.patch: Remove. * nongnu/packages/patches/broadcom-sta-rdtscl.patch: Remove. * README.org (Broadcom Wireless): Removed recommendation from Broadcom Wireless section. Signed-off-by: Jonathan Brielmaier <jonathan.brielmaier@web.de>
Diffstat (limited to 'nongnu/packages/patches/broadcom-sta-null-pointer-fix.patch')
-rw-r--r--nongnu/packages/patches/broadcom-sta-null-pointer-fix.patch27
1 files changed, 0 insertions, 27 deletions
diff --git a/nongnu/packages/patches/broadcom-sta-null-pointer-fix.patch b/nongnu/packages/patches/broadcom-sta-null-pointer-fix.patch
deleted file mode 100644
index adef19f..0000000
--- a/nongnu/packages/patches/broadcom-sta-null-pointer-fix.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-Description: Fixing null pointer crash
-
-Origin: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=773713
-Bug-Ubuntu: https://launchpad.net/bugs/1415880
-Last-Update: 2015-08-18
-
----
- src/wl/sys/wl_linux.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/wl/sys/wl_linux.c b/src/wl/sys/wl_linux.c
-index 860b935..295156f 100644
---- a/src/wl/sys/wl_linux.c
-+++ b/src/wl/sys/wl_linux.c
-@@ -2157,8 +2157,8 @@ wl_start(struct sk_buff *skb, struct net_device *dev)
- wlif = WL_DEV_IF(dev);
- wl = WL_INFO(dev);
-
-+ skb->prev = NULL;
- if (WL_ALL_PASSIVE_ENAB(wl) || (WL_RTR() && WL_CONFIG_SMP())) {
-- skb->prev = NULL;
-
- TXQ_LOCK(wl);
-
---
-1.9.1
-