summaryrefslogtreecommitdiff
path: root/nongnu/packages/patches/broadcom-sta-rdtscl.patch
diff options
context:
space:
mode:
authorAlex Griffin <a@ajgrf.com>2019-05-30 03:48:38 -0500
committerAlex Griffin <a@ajgrf.com>2019-05-30 05:43:32 -0500
commit5b9fbf947411587f9bb54f123fa1501b7fc60b7a (patch)
treec72b60915b2ca11dd3a20311ffd9a72f2a0eae8c /nongnu/packages/patches/broadcom-sta-rdtscl.patch
parent7513783896aaa99500bd24d7ad9987892450f9c7 (diff)
nongnu: Add broadcom-sta.
* nongnu/packages/linux.scm (broadcom-sta): New variable. * nongnu/packages/patches/broadcom-sta-debian-fix-kernel-warnings.patch: New file. * nongnu/packages/patches/broadcom-sta-fix_mac_profile_discrepancy.patch: New file. * nongnu/packages/patches/broadcom-sta-gcc.patch: New file. * nongnu/packages/patches/broadcom-sta-license.patch: New file. * nongnu/packages/patches/broadcom-sta-linux-4.11.patch: New file. * nongnu/packages/patches/broadcom-sta-linux-4.12.patch: New file. * nongnu/packages/patches/broadcom-sta-linux-4.15.patch: New file. * nongnu/packages/patches/broadcom-sta-linux-4.7.patch: New file. * nongnu/packages/patches/broadcom-sta-linux-4.8.patch: New file. * nongnu/packages/patches/broadcom-sta-linux-5.1.patch: New file. * nongnu/packages/patches/broadcom-sta-null-pointer-fix.patch: New file. * nongnu/packages/patches/broadcom-sta-rdtscl.patch: New file.
Diffstat (limited to 'nongnu/packages/patches/broadcom-sta-rdtscl.patch')
-rw-r--r--nongnu/packages/patches/broadcom-sta-rdtscl.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/nongnu/packages/patches/broadcom-sta-rdtscl.patch b/nongnu/packages/patches/broadcom-sta-rdtscl.patch
new file mode 100644
index 0000000..1b9862c
--- /dev/null
+++ b/nongnu/packages/patches/broadcom-sta-rdtscl.patch
@@ -0,0 +1,22 @@
+Since Linux 4.3, rdtscl() is no longer available and native_read_tsc()
+is renamed to rdtsc(). Move the macro contents in-line and call the
+new function. References:
+
+https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit?id=fe47ae6e1a5005b2e82f7eab57b5c3820453293a
+https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit?id=4ea1636b04dbd66536fa387bae2eea463efc705b
+
+diff -ru a/src/shared/linux_osl.c b/src/shared/linux_osl.c
+--- a/src/shared/linux_osl.c 2015-09-19 01:47:15.000000000 +0300
++++ b/src/shared/linux_osl.c 2015-11-21 15:20:30.585902518 +0200
+@@ -932,7 +932,11 @@
+ uint cycles;
+
+ #if defined(__i386__)
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 3, 0)
++ cycles = (u32)rdtsc();
++#else
+ rdtscl(cycles);
++#endif
+ #else
+ cycles = 0;
+ #endif