summaryrefslogtreecommitdiff
path: root/nongnu/packages/patches
diff options
context:
space:
mode:
authorJames Smith <jsubuntuxp@disroot.org>2020-10-25 13:36:28 -0700
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2020-10-26 08:26:26 +0100
commit9efcb6799cb3baf3db404e997141ef7a5d06d877 (patch)
tree4fffa6e679c76eb850ec213a2bea5a8c63d52c98 /nongnu/packages/patches
parent9256536ad279a5e369644d581294ed252760f0c9 (diff)
nongnu: broadcom-sta: Fix build on linux 5.9 and later.
* nongnu/packages/linux.scm (broadcom-sta-x86_64-source)[patches]: Use patch. * nongnu/packages/patches/broadcom-sta-linux-5.9.patch: New patch from Arch Linux (without already applied hunks). Closes https://gitlab.com/nonguix/nonguix/-/merge_requests/55. Signed-off-by: Jonathan Brielmaier <jonathan.brielmaier@web.de>
Diffstat (limited to 'nongnu/packages/patches')
-rw-r--r--nongnu/packages/patches/broadcom-sta-linux-5.9.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/nongnu/packages/patches/broadcom-sta-linux-5.9.patch b/nongnu/packages/patches/broadcom-sta-linux-5.9.patch
new file mode 100644
index 0000000..56de11d
--- /dev/null
+++ b/nongnu/packages/patches/broadcom-sta-linux-5.9.patch
@@ -0,0 +1,12 @@
+diff -u -r a/src/wl/sys/wl_linux.c b/src/wl/sys/wl_linux.c
+--- a/src/wl/sys/wl_linux.c 2020-10-12 21:19:15.256305165 +0000
++++ b/src/wl/sys/wl_linux.c 2020-10-12 21:20:38.687530895 +0000
+@@ -1643,7 +1643,7 @@
+ goto done2;
+ }
+
+- if (segment_eq(get_fs(), KERNEL_DS))
++ if (get_fs().seg == KERNEL_DS.seg)
+ buf = ioc.buf;
+
+ else if (ioc.buf) {