summaryrefslogtreecommitdiff
path: root/nongnu/packages/steam-client.scm
diff options
context:
space:
mode:
authorison <ison@airmail.cc>2020-09-03 20:22:43 -0600
committerPierre Neidhardt <mail@ambrevar.xyz>2020-09-04 08:47:18 +0200
commita7a126daff56ca30ce6c9b05290adb96ec943239 (patch)
treec91c0f6c93608e60a6101310afdb7aa3cc45974a /nongnu/packages/steam-client.scm
parent827b21bd392dbdcd65c042ee3f98c9a2cf9f34ac (diff)
nongnu: steam: Fix Desktop file and clean manifest.
nongnu/packages/steam-client.scm (steam)[steam.desktop]: Fix Exec typo. [manifest]: Rename to manifest.scm, add newlines and comment.
Diffstat (limited to 'nongnu/packages/steam-client.scm')
-rw-r--r--nongnu/packages/steam-client.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/nongnu/packages/steam-client.scm b/nongnu/packages/steam-client.scm
index 8a0c8ba..9a05de8 100644
--- a/nongnu/packages/steam-client.scm
+++ b/nongnu/packages/steam-client.scm
@@ -367,7 +367,7 @@ in the Guix store"
(add-after 'unpack 'patch-desktop-file
(lambda _
(substitute* "steam.desktop"
- (("Exec=/usr/bin/steam") "Exec=steam-sandbox"))
+ (("Exec=/usr/bin/steam") "Exec=steam"))
#t))
;; /bin/steamdeps allows Steam to install missing packages, which doesn't play well with Guix, so remove it.
(add-after 'install-binaries 'remove-unneccessary-file
@@ -392,7 +392,7 @@ in the Guix store"
(steam-real (move-file (string-append out "/bin/steam")
(string-append out "/bin/.steam-real")))
(manifest-dir (string-append out "/etc"))
- (manifest-path (string-append manifest-dir "/manifest"))
+ (manifest-path (string-append manifest-dir "/manifest.scm"))
(sandbox (string-append out "/bin/steam"))
(sandbox-helper (string-append out "/bin/.sandbox-helper"))
(steam-libs-32 (assoc-ref inputs "steam-libs-32"))
@@ -413,6 +413,8 @@ in the Guix store"
(guix profiles)
(guix store)
(srfi srfi-11))
+
+;;; Copied from guix/scripts/package.scm
(define (store-item->manifest-entry item)
\"Return a manifest entry for ITEM, a \\\"/gnu/store/...\\\" file name.\"
(let-values (((name version)
@@ -423,6 +425,7 @@ in the Guix store"
(version version)
(output \"out\") ;XXX: wild guess
(item item))))
+
(manifest-add
(packages->manifest
(list coreutils
@@ -476,7 +479,7 @@ guix environment --ad-hoc --container --no-cwd --network \\
--expose=/sys/devices \\
--expose=/dev/dri \\
--share=/dev/shm \\
- -m \"" out "/etc/manifest\" \\
+ -m \"" manifest-path "\" \\
\"${shell_command[@]}\"\n"))
(chmod sandbox #o555)