summaryrefslogtreecommitdiff
path: root/nongnu
diff options
context:
space:
mode:
authorAlex Griffin <a@ajgrf.com>2019-06-02 20:43:52 -0500
committerAlex Griffin <a@ajgrf.com>2019-06-02 20:43:52 -0500
commitd81e40f020756019997e12217fd19bfbeab3c9d5 (patch)
tree97489944690c66b3b9dc3cb99f6b96da43afd7b2 /nongnu
parent093ead7263da6a007c11295b866b27c153b406ab (diff)
nongnu: Add amdgpu-firmware.
* nongnu/packages/linux.scm (amdgpu-firmware): New variable.
Diffstat (limited to 'nongnu')
-rw-r--r--nongnu/packages/linux.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/nongnu/packages/linux.scm b/nongnu/packages/linux.scm
index 7173345..a8c9519 100644
--- a/nongnu/packages/linux.scm
+++ b/nongnu/packages/linux.scm
@@ -104,6 +104,35 @@ if your hardware is supported by one of the smaller firmware packages.")
(string-append "https://git.kernel.org/pub/scm/linux/kernel/git/"
"firmware/linux-firmware.git/plain/WHENCE"))))))
+(define-public amdgpu-firmware
+ (package
+ (inherit linux-firmware)
+ (name "amdgpu-firmware")
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let* ((source (assoc-ref %build-inputs "source"))
+ (fw-dir (string-append %output "/lib/firmware/"))
+ (bin-dir (string-append fw-dir "/amdgpu")))
+ (mkdir-p bin-dir)
+ (copy-recursively (string-append source "/amdgpu") bin-dir)
+ (install-file (string-append source "/LICENSE.amdgpu") fw-dir)
+ #t))))
+ (home-page "http://support.amd.com/en-us/download/linux")
+ (synopsis "Nonfree firmware for AMD graphics chips")
+ (description "Nonfree firmware for AMD graphics chips. While most AMD
+graphics cards can be run with the free Mesa, many modern cards require a
+nonfree kernel module to run properly and support features like hibernation and
+advanced 3D.")
+ (license
+ (nonfree
+ (string-append
+ "https://git.kernel.org/pub/scm/linux/kernel/git/firmware"
+ "/linux-firmware.git/plain/LICENSE.amdgpu")))))
+
(define-public ath3k-firmware
(package
(inherit linux-firmware)