summaryrefslogtreecommitdiff
path: root/nongnu
diff options
context:
space:
mode:
authorJonathan Brielmaier <jonathan.brielmaier@web.de>2020-10-21 12:39:10 +0200
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2020-10-21 12:39:10 +0200
commit02cf886efac46de75a1226128a7cc4534ef426d2 (patch)
tree29ffabf87857aced06f04b8c11660121d8156f76 /nongnu
parentee08c44091ac4c99b594de2284bdea8383f37f1c (diff)
nongnu: firefox: Update to 82.0.
* nongnu/packages/mozilla.scm (firefox): Update to 82.0. [arguments]: `obj-x86_64-pc-linux-gnu` folder was removed by upstream, so we don't need to do that anymore. [native-inputs]: Add m4 and import module.
Diffstat (limited to 'nongnu')
-rw-r--r--nongnu/packages/mozilla.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/nongnu/packages/mozilla.scm b/nongnu/packages/mozilla.scm
index ae102a7..f888903 100644
--- a/nongnu/packages/mozilla.scm
+++ b/nongnu/packages/mozilla.scm
@@ -62,6 +62,7 @@
#:use-module (gnu packages libffi)
#:use-module (gnu packages libreoffice) ;for hunspell
#:use-module (gnu packages llvm)
+ #:use-module (gnu packages m4)
#:use-module (gnu packages node)
#:use-module (gnu packages nss)
#:use-module (gnu packages perl)
@@ -99,19 +100,19 @@
;; Update this id with every firefox update to it's release date.
;; It's used for cache validation and therefor can lead to strange bugs.
-(define %firefox-build-id "20201013000000")
+(define %firefox-build-id "20201020000000")
(define-public firefox
(package
(name "firefox")
- (version "81.0.2")
+ (version "82.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://archive.mozilla.org/pub/firefox/releases/"
version "/source/firefox-" version ".source.tar.xz"))
(sha256
- (base32 "0i4vkx7phhgynyxrg4j291m680d02n8bka6r3yfv34xix4nlidli"))))
+ (base32 "1hk4sk2qjbxfjfc9c3s3g04dqvjmcgjdpjhv5n79fd5xyl3qgich"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -165,7 +166,6 @@
(lambda _
(delete-file "configure")
(delete-file "js/src/configure")
- (delete-file-recursively "obj-x86_64-pc-linux-gnu")
#t))
(add-after 'unpack 'fix-preferences
(lambda* (#:key inputs #:allow-other-keys)
@@ -398,6 +398,7 @@
("cargo" ,rust-1.43 "cargo")
("clang" ,clang)
("llvm" ,llvm)
+ ("m4" ,m4)
("nasm" ,nasm)
("node" ,node-10.22)
("perl" ,perl)