summaryrefslogtreecommitdiff
path: root/nongnu
diff options
context:
space:
mode:
authorJonathan Brielmaier <jonathan.brielmaier@web.de>2020-09-23 10:45:50 +0200
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2020-10-02 14:58:58 +0200
commit1e0ebd4312105ba0de0b297f13c3292d6b6bd4af (patch)
tree93c97c88f07612a404ea5e014013f147d15293cf /nongnu
parent75569aa3f82821572fef6bce9c4c600ad8bce044 (diff)
nongnu: firefox: Update to 81.0.1.
* nongnu/packages/mozilla.scm (firefox): Update to 81.0.1. [arguments]: Use system python for mach with MACH_USE_SYSTEM_PYTHON. (%firefox-build-id): Add comment why updating this id is important.
Diffstat (limited to 'nongnu')
-rw-r--r--nongnu/packages/mozilla.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/nongnu/packages/mozilla.scm b/nongnu/packages/mozilla.scm
index 3fc7e84..2536c14 100644
--- a/nongnu/packages/mozilla.scm
+++ b/nongnu/packages/mozilla.scm
@@ -97,19 +97,21 @@
`(("rust-heck" ,rust-heck-0.3)
,@cargo-inputs)))))))
-(define %firefox-build-id "20200908000000")
+;; Update this id with every firefox update to it's release date.
+;; It's used for cache validation and therefor can lead to strange bugs.
+(define %firefox-build-id "20201001000000")
(define-public firefox
(package
(name "firefox")
- (version "80.0.1")
+ (version "81.0.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://archive.mozilla.org/pub/firefox/releases/"
version "/source/firefox-" version ".source.tar.xz"))
(sha256
- (base32 "089ck6pq73nlw1bgjjvdaw7zjwb2bjk1w5hfjsx87mm269g0hssr"))))
+ (base32 "1zwg1rrqnn4cl1pn2dr7zajslf1iiiwrvmwv1vry107mm8z8vb3y"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -236,6 +238,7 @@
(setenv "CONFIG_SHELL" (which "bash"))
(setenv "PYTHON" (string-append (assoc-ref inputs "python2")
"/bin/python"))
+ (setenv "MACH_USE_SYSTEM_PYTHON" "1")
;; Use Clang, Clang is 2x faster than GCC
(setenv "AR" "llvm-ar") (setenv "NM" "llvm-nm")