summaryrefslogtreecommitdiff
path: root/nongnu
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-04-01 16:31:47 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2020-04-01 16:31:47 +0200
commit28c7b2a25917190cab8304a7856e04d71c709471 (patch)
tree836869af490d60cad9ceed3f3088282b2848ec01 /nongnu
parentc523c62ec1ccf3637f29b086d13934e91ed7bacd (diff)
gnu: Add radeon-firmware.
* nongnu/packages/linux.scm (radeon-firmware): New variable.
Diffstat (limited to 'nongnu')
-rw-r--r--nongnu/packages/linux.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/nongnu/packages/linux.scm b/nongnu/packages/linux.scm
index ab8a107..effcee8 100644
--- a/nongnu/packages/linux.scm
+++ b/nongnu/packages/linux.scm
@@ -140,6 +140,30 @@ advanced 3D.")
"https://git.kernel.org/pub/scm/linux/kernel/git/firmware"
"/linux-firmware.git/plain/LICENSE.amdgpu")))))
+(define-public radeon-firmware
+ (package
+ (inherit amdgpu-firmware)
+ (name "radeon-firmware")
+ (arguments
+ `(#:tests? #f
+ #:license-file-regexp "LICENSE.radeon"
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (fw-dir (string-append out "/lib/firmware"))
+ (bin-dir (string-append fw-dir "/radeon")))
+ (mkdir-p bin-dir)
+ (copy-recursively "./radeon" bin-dir)
+ #t)))
+ (delete 'validate-runpath))))
+ (synopsis "Nonfree firmware for older AMD graphics chips")
+ (description "Nonfree firmware for AMD graphics chips. While most AMD
+graphics cards can be run with the free Mesa, some cards require a nonfree
+kernel module to run properly and support features like hibernation and
+advanced 3D.")))
+
(define-public atheros-firmware
(package
(inherit linux-firmware)