summaryrefslogtreecommitdiff
path: root/nongnu
diff options
context:
space:
mode:
authorAlex Griffin <a@ajgrf.com>2019-05-29 12:21:13 -0500
committerAlex Griffin <a@ajgrf.com>2019-05-29 12:21:13 -0500
commit50b80b7c71b6d4e5c7917d9b79d500b1d3aeafef (patch)
tree62b4fa41faffecf0ab71449aa6e6fc5693ed732a /nongnu
parentd62d274fb3ac420ff2c77adbc2fc82bd7ec5f902 (diff)
nongnu: ath3k-firmware: Include licenses in output.
* nongnu/packages/linux.scm (ath3k-firmware)[arguments]: Include licenses in output.
Diffstat (limited to 'nongnu')
-rw-r--r--nongnu/packages/linux.scm26
1 files changed, 16 insertions, 10 deletions
diff --git a/nongnu/packages/linux.scm b/nongnu/packages/linux.scm
index 4d01dba..0952f44 100644
--- a/nongnu/packages/linux.scm
+++ b/nongnu/packages/linux.scm
@@ -109,16 +109,22 @@ hardware in the Linux kernel.")
(build-system trivial-build-system)
(arguments
`(#:modules ((guix build utils))
- #:builder (begin
- (use-modules (guix build utils))
- (let ((source (assoc-ref %build-inputs "source"))
- (fw-dir (string-append %output "/lib/firmware")))
- (mkdir-p fw-dir)
- (copy-file (string-append source "/ath3k-1.fw")
- (string-append fw-dir "/ath3k-1.fw"))
- (copy-recursively (string-append source "/ar3k")
- (string-append fw-dir "/ar3k"))
- #t))))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((source (assoc-ref %build-inputs "source"))
+ (fw-dir (string-append %output "/lib/firmware")))
+ (mkdir-p fw-dir)
+ (for-each (lambda (file)
+ (copy-file (string-append source "/" file)
+ (string-append fw-dir "/" file)))
+ (list "ath3k-1.fw"
+ "LICENCE.atheros_firmware"
+ "LICENSE.QualcommAtheros_ar3k"
+ "WHENCE"))
+ (copy-recursively (string-append source "/ar3k")
+ (string-append fw-dir "/ar3k"))
+ #t))))
(synopsis "Nonfree firmware blobs for the ath3k Bluetooth driver")
(description "Nonfree firmware blobs for the ath3k Bluetooth driver. ath3k
is the Linux Bluetooth driver for Atheros AR3011/AR3012 Bluetooth chipsets.")