summaryrefslogtreecommitdiff
path: root/nongnu
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2020-10-02 11:12:41 +0200
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2020-10-02 16:21:51 +0200
commit5d83bd2e981b1b0f0fc8ce49042d769ebb4bb1dc (patch)
treeacaa02e9b0ae3a3882cd3f88ee3db0c766f7981d /nongnu
parente3c50e1385cc70f2c74aa6dad85c76ed513aa483 (diff)
nongnu: eduke32: Remove unnecessary phase.
Since commit 2073b55, Guix uses CPLUS_INCLUDE_PATH to find system headers. Overriding this variable caused a compile failure. The package builds fine without it, so just drop it. * nongnu/packages/game-development.scm (eduke32)[arguments]: Drop ‘set-sdl-paths’ phase. Signed-off-by: Jonathan Brielmaier <jonathan.brielmaier@web.de>
Diffstat (limited to 'nongnu')
-rw-r--r--nongnu/packages/game-development.scm10
1 files changed, 0 insertions, 10 deletions
diff --git a/nongnu/packages/game-development.scm b/nongnu/packages/game-development.scm
index 95facd2..00ebb00 100644
--- a/nongnu/packages/game-development.scm
+++ b/nongnu/packages/game-development.scm
@@ -214,16 +214,6 @@ development should opt for GLSL rather than Cg.")
'("multivoc.cpp" "xmp.cpp")))
#t))
(delete 'configure)
- (add-after 'set-paths 'set-sdl-paths
- ;; The makefile adds the output of `sdl2-config --cflags` to the
- ;; compiler flags, but sdl2-config gives us the wrong directory to
- ;; include. We have to add the SDL2 header directory ourselves.
- (lambda* (#:key inputs #:allow-other-keys)
- (pk (assoc-ref inputs "sdl-union"))
- (setenv "CPLUS_INCLUDE_PATH"
- (string-append (assoc-ref inputs "sdl-union")
- "/include/SDL2"))
- #t))
(replace 'install
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))