summaryrefslogtreecommitdiff
path: root/nongnu
diff options
context:
space:
mode:
authorAlex Griffin <a@ajgrf.com>2019-05-26 17:48:44 -0500
committerAlex Griffin <a@ajgrf.com>2019-05-26 17:52:04 -0500
commita00815c40d230e235f9619cb90fca04dcd2d6dfc (patch)
tree512a6e6dbc111eb610b12c7341455a72f9e440a3 /nongnu
parentb51327e5f4b845450517c8f55360180e0af7e19d (diff)
nongnu: linux: Make use of nonfree license definitions.
* nongnu/packages/linux.scm (linux-firmware)[license]: Specify nonfree license. * nongnu/packages/linux.scm (ath3k-firmware)[license]: Specify nonfree license.
Diffstat (limited to 'nongnu')
-rw-r--r--nongnu/packages/linux.scm16
1 files changed, 13 insertions, 3 deletions
diff --git a/nongnu/packages/linux.scm b/nongnu/packages/linux.scm
index 679f9c5..805fd85 100644
--- a/nongnu/packages/linux.scm
+++ b/nongnu/packages/linux.scm
@@ -26,7 +26,7 @@
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix build-system trivial)
- #:use-module ((guix licenses) #:prefix license:))
+ #:use-module (nonguix licenses))
(define (linux-urls version)
"Return a list of URLS for Linux VERSION."
@@ -87,7 +87,7 @@ on hardware which requires nonfree software to function.")))
(description "Non-free firmware blobs for enabling support for various
hardware in the Linux kernel.")
(license
- (license:non-copyleft
+ (nonfree
(string-append "https://git.kernel.org/pub/scm/linux/kernel/git/"
"firmware/linux-firmware.git/plain/WHENCE"))))))
@@ -110,4 +110,14 @@ hardware in the Linux kernel.")
#t))))
(synopsis "Non-free firmware blobs for the ath3k Bluetooth driver")
(description "Non-free firmware blobs for the ath3k Bluetooth driver. ath3k
-is the Linux Bluetooth driver for Atheros AR3011/AR3012 Bluetooth chipsets.")))
+is the Linux Bluetooth driver for Atheros AR3011/AR3012 Bluetooth chipsets.")
+ (license
+ (list
+ (nonfree
+ (string-append
+ "https://git.kernel.org/pub/scm/linux/kernel/git/firmware"
+ "/linux-firmware.git/plain/LICENCE.atheros_firmware"))
+ (nonfree
+ (string-append
+ "https://git.kernel.org/pub/scm/linux/kernel/git/firmware"
+ "/linux-firmware.git/plain/LICENSE.QualcommAtheros_ar3k"))))))