summaryrefslogtreecommitdiff
path: root/nongnu
diff options
context:
space:
mode:
authorAlex Griffin <a@ajgrf.com>2019-05-29 11:43:10 -0500
committerAlex Griffin <a@ajgrf.com>2019-05-29 11:55:08 -0500
commitd62d274fb3ac420ff2c77adbc2fc82bd7ec5f902 (patch)
tree4d4c64b5a3fe2e03e8bfb4c619fb9d9a1d644844 /nongnu
parentcdeeeada084932edea1d18610e47ab72b0b11efc (diff)
nongnu: linux-firmware: Use Ambrevar's build system instead.
* nongnu/packages/linux.scm: Replace probably-redundant copyright attributions with Pierre Neidhardt instead. (linux-firmware): Use his build system instead of the one from Andy Wingo's guix-nonfree repository.
Diffstat (limited to 'nongnu')
-rw-r--r--nongnu/packages/linux.scm14
1 files changed, 4 insertions, 10 deletions
diff --git a/nongnu/packages/linux.scm b/nongnu/packages/linux.scm
index 65648f9..4d01dba 100644
--- a/nongnu/packages/linux.scm
+++ b/nongnu/packages/linux.scm
@@ -1,11 +1,5 @@
;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
-;;; Copyright © 2012, 2013, 2014, 2015, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
-;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
-;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
-;;; Copyright © 2015, 2017, 2018 Andy Wingo <wingo@igalia.com>
+;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
;;;
;;; This program is free software: you can redistribute it and/or modify
;;; it under the terms of the GNU General Public License as published by
@@ -94,9 +88,9 @@ on hardware which requires nonfree software to function.")))
#:builder (begin
(use-modules (guix build utils))
(let ((source (assoc-ref %build-inputs "source"))
- (fw-dir (string-append %output "/lib/firmware/")))
- (mkdir-p fw-dir)
- (copy-recursively source fw-dir)
+ (destination (string-append %output "/lib/firmware")))
+ (mkdir-p destination)
+ (copy-recursively source destination #:follow-symlinks? #t)
#t))))
(home-page
"http://git.kernel.org/?p=linux/kernel/git/firmware/linux-firmware.git")