summaryrefslogtreecommitdiff
path: root/nongnu
diff options
context:
space:
mode:
authorAlex Griffin <a@ajgrf.com>2019-05-29 12:43:22 -0500
committerAlex Griffin <a@ajgrf.com>2019-05-29 12:44:04 -0500
commite9be404d94593209a2a4febb3cb14103db9752eb (patch)
treed1432d5875bfabee53bc4748cb9f053b2a5e556e /nongnu
parentbacfd8d681228e210e29e52dc17da7926b6a1f22 (diff)
nongnu: Add iwlwifi-firmware.
* nongnu/packages/linux.scm (iwlwifi-firmware): New variable.
Diffstat (limited to 'nongnu')
-rw-r--r--nongnu/packages/linux.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/nongnu/packages/linux.scm b/nongnu/packages/linux.scm
index 323abcf..b48077d 100644
--- a/nongnu/packages/linux.scm
+++ b/nongnu/packages/linux.scm
@@ -140,6 +140,37 @@ is the Linux Bluetooth driver for Atheros AR3011/AR3012 Bluetooth chipsets.")
"https://git.kernel.org/pub/scm/linux/kernel/git/firmware"
"/linux-firmware.git/plain/LICENSE.QualcommAtheros_ar3k"))))))
+(define-public iwlwifi-firmware
+ (package
+ (inherit linux-firmware)
+ (name "iwlwifi-firmware")
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((source (assoc-ref %build-inputs "source"))
+ (fw-dir (string-append %output "/lib/firmware/")))
+ (mkdir-p fw-dir)
+ (for-each (lambda (file)
+ (copy-file file
+ (string-append fw-dir (basename file))))
+ (cons*
+ (string-append source "/LICENCE.iwlwifi_firmware")
+ (find-files source
+ "iwlwifi-.*\\.ucode$")))
+ #t))))
+ (home-page "https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi")
+ (synopsis "Nonfree firmware for Intel wifi chips")
+ (description "The proprietary iwlwifi kernel module is required by many
+modern Intel wifi cards (commonly found in laptops). This blob enables
+support for 5GHz and 802.11ac, among others.")
+ (license
+ (nonfree (string-append
+ "https://git.kernel.org/pub/scm/linux/kernel/git/firmware"
+ "/linux-firmware.git/plain/LICENCE.iwlwifi_firmware")))))
+
(define-public broadcom-bt-firmware
(package
(name "broadcom-bt-firmware")