summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--nongnu/packages/linux.scm3
-rw-r--r--nongnu/packages/patches/broadcom-sta-linux-5.9.patch12
2 files changed, 14 insertions, 1 deletions
diff --git a/nongnu/packages/linux.scm b/nongnu/packages/linux.scm
index 96f50fe..aa15d9e 100644
--- a/nongnu/packages/linux.scm
+++ b/nongnu/packages/linux.scm
@@ -558,7 +558,8 @@ package contains nonfree firmware for the following chips:
"broadcom-sta-fix_mac_profile_discrepancy.patch"
"broadcom-sta-linux-5.1.patch"
;; source: https://github.com/NixOS/nixpkgs/commit/8ce65087c333097ab714d23800b69fc471ec48ca
- "broadcom-sta-linux-5.6.patch")))
+ "broadcom-sta-linux-5.6.patch"
+ "broadcom-sta-linux-5.9.patch")))
(sha256
(base32
"1gj485qqr190idilacpxwgqyw21il03zph2rddizgj7fbd6pfyaz"))))
diff --git a/nongnu/packages/patches/broadcom-sta-linux-5.9.patch b/nongnu/packages/patches/broadcom-sta-linux-5.9.patch
new file mode 100644
index 0000000..56de11d
--- /dev/null
+++ b/nongnu/packages/patches/broadcom-sta-linux-5.9.patch
@@ -0,0 +1,12 @@
+diff -u -r a/src/wl/sys/wl_linux.c b/src/wl/sys/wl_linux.c
+--- a/src/wl/sys/wl_linux.c 2020-10-12 21:19:15.256305165 +0000
++++ b/src/wl/sys/wl_linux.c 2020-10-12 21:20:38.687530895 +0000
+@@ -1643,7 +1643,7 @@
+ goto done2;
+ }
+
+- if (segment_eq(get_fs(), KERNEL_DS))
++ if (get_fs().seg == KERNEL_DS.seg)
+ buf = ioc.buf;
+
+ else if (ioc.buf) {