summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--nongnu/packages/gog.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/nongnu/packages/gog.scm b/nongnu/packages/gog.scm
index c1c981f..adc5dc5 100644
--- a/nongnu/packages/gog.scm
+++ b/nongnu/packages/gog.scm
@@ -43,7 +43,15 @@
(sha256
(base32 "0a3rrkgqwdqxx3ghzw182jx88gzzw6ldp3jasmgnr4l7gpxkmwws"))))
(build-system cmake-build-system)
- (arguments '(#:tests? #f)) ; no tests
+ (arguments
+ `(#:tests? #f ; no tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'patch-find-jsoncpp
+ (lambda* _
+ (substitute* "cmake/FindJsoncpp.cmake"
+ (("features.h") "allocator.h"))
+ #t)))))
(inputs
`(("boost" ,boost)
("curl" ,curl)