summaryrefslogtreecommitdiff
path: root/guix/nongnu/packages/clojure.scm
diff options
context:
space:
mode:
Diffstat (limited to 'guix/nongnu/packages/clojure.scm')
-rw-r--r--guix/nongnu/packages/clojure.scm174
1 files changed, 174 insertions, 0 deletions
diff --git a/guix/nongnu/packages/clojure.scm b/guix/nongnu/packages/clojure.scm
new file mode 100644
index 0000000..195c743
--- /dev/null
+++ b/guix/nongnu/packages/clojure.scm
@@ -0,0 +1,174 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2020 Jelle Licht <jlicht@fsfe.org>
+;;; Copyright © 2020 Alex Griffin <a@ajgrf.com>
+;;;
+;;; This file is not part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (nongnu packages clojure)
+ #:use-module (gnu packages compression)
+ #:use-module (gnu packages gcc)
+ #:use-module (gnu packages readline)
+ #:use-module (guix build-system copy)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix build-system trivial)
+ #:use-module (guix download)
+ #:use-module (guix git-download)
+ #:use-module (guix packages)
+ #:use-module (nonguix build-system binary)
+ #:use-module ((guix licenses) #:prefix license:))
+
+(define-public clojure-tools
+ (package
+ (name "clojure-tools")
+ (version "1.10.3.1029")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://download.clojure.org/install/clojure-tools-"
+ version
+ ".tar.gz"))
+ (sha256 (base32 "14c08xva1r6sl3h78vhckwx5dd8kqwi7457prygh9330b7r8caa2"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan
+ '(("deps.edn" "lib/clojure/")
+ ("example-deps.edn" "lib/clojure/")
+ ("tools.edn" "lib/clojure/")
+ ("exec.jar" "lib/clojure/libexec/")
+ (,(string-append "clojure-tools-" version ".jar") "lib/clojure/libexec/")
+ ("clojure" "bin/")
+ ("clj" "bin/"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-paths
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "clojure"
+ (("PREFIX") (string-append (assoc-ref outputs "out") "/lib/clojure")))
+ (substitute* "clj"
+ (("BINDIR") (string-append (assoc-ref outputs "out") "/bin"))
+ (("rlwrap") (which "rlwrap")))
+ #true)))))
+ (inputs `(("rlwrap" ,rlwrap)))
+ (synopsis "CLI tools for the Clojure programming language")
+ (description "The Clojure command line tools can be used to start
+a Clojure repl, use Clojure and Java libraries, and start Clojure
+programs.")
+ (license license:epl1.0)
+ (home-page "https://clojure.org/releases/tools")))
+
+
+;; This is a hidden package, as it does not really serve a purpose on its own.
+(define leiningen-jar
+ (package
+ (name "leiningen-jar")
+ (version "2.9.8")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/technomancy/leiningen/releases/download/"
+ version "/leiningen-" version "-standalone.jar"))
+ (file-name "leiningen-standalone.jar")
+ (sha256
+ (base32
+ "13f4n15i0gsk9jq52gxivnsk32qjahmxgrddm54cf8ynw0a923ia"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder (begin
+ (use-modules (guix build utils))
+ (let ((source (assoc-ref %build-inputs "source"))
+ (jar-dir (string-append %output "/share/")))
+ (mkdir-p jar-dir)
+ (copy-file source
+ (string-append jar-dir "leiningen-standalone.jar"))))))
+ (home-page "https://leiningen.org")
+ (synopsis "Automate Clojure projects without setting your hair on fire")
+ (description "Leiningen is a Clojure tool with a focus on project
+automation and declarative configuration. It gets out of your way and
+lets you focus on your code.")
+ (license license:epl1.0)))
+
+(define-public leiningen
+ (package
+ (inherit leiningen-jar)
+ (name "leiningen")
+ (version "2.9.8")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/technomancy/leiningen.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1i6pn8vzzhgnm9hmlb92z65l79nxcxa5zdsrgg5svq7vmbixgnhl"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f
+ #:phases (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (replace 'install
+ (lambda _
+ (let* ((lein-pkg (string-append (assoc-ref %build-inputs "source") "/bin/lein-pkg"))
+ (lein-jar (string-append (assoc-ref %build-inputs "leiningen-jar")
+ "/share/leiningen-standalone.jar"))
+ (bin-dir (string-append %output "/bin"))
+ (lein (string-append bin-dir "/lein")))
+ (mkdir-p bin-dir)
+ (copy-file lein-pkg lein)
+ (patch-shebang lein)
+ (chmod lein #o555)
+ (substitute* lein
+ (("LEIN_JAR=.*") (string-append "LEIN_JAR=" lein-jar)))
+ #t))))))
+ (inputs
+ `(("leiningen-jar" ,leiningen-jar)))))
+
+(define-public clj-kondo
+ (package
+ (name "clj-kondo")
+ (version "2021.10.19")
+ (source (origin
+ (method url-fetch/zipbomb)
+ (uri (string-append
+ "https://github.com/clj-kondo/clj-kondo/releases/download/v"
+ version "/clj-kondo-" version "-linux-amd64.zip"))
+ (sha256
+ (base32
+ "1xiv7waaj2lkfxszaklg59gkkfsrqh39i3a8bj9slq6lg80q7lxs"))))
+ (build-system binary-build-system)
+ (arguments
+ `(#:patchelf-plan
+ '(("clj-kondo" ("gcc:lib" "zlib")))
+ #:install-plan
+ '(("clj-kondo" "/bin/"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chmod
+ (lambda _
+ (chmod "clj-kondo" #o755))))))
+ (native-inputs
+ `(("unzip" ,unzip)))
+ (inputs
+ `(("gcc:lib" ,gcc "lib")
+ ("zlib" ,zlib)))
+ (supported-systems '("x86_64-linux"))
+ (home-page "https://github.com/clj-kondo/clj-kondo")
+ (synopsis "Linter for Clojure code")
+ (description "Clj-kondo performs static analysis on Clojure, ClojureScript
+and EDN, without the need of a running REPL.")
+ (license license:epl1.0)))