summaryrefslogtreecommitdiff
path: root/guix/nongnu/packages/patches/broadcom-sta-linux-5.1.patch
diff options
context:
space:
mode:
Diffstat (limited to 'guix/nongnu/packages/patches/broadcom-sta-linux-5.1.patch')
-rw-r--r--guix/nongnu/packages/patches/broadcom-sta-linux-5.1.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/guix/nongnu/packages/patches/broadcom-sta-linux-5.1.patch b/guix/nongnu/packages/patches/broadcom-sta-linux-5.1.patch
new file mode 100644
index 0000000..8f04a73
--- /dev/null
+++ b/guix/nongnu/packages/patches/broadcom-sta-linux-5.1.patch
@@ -0,0 +1,32 @@
+commit bcb06af629a36eb84f9a35ac599ec7e51e2d39fb
+Author: georgewhewell <georgerw@gmail.com>
+Date: Sat May 18 21:22:37 2019 +0100
+
+ find src -type f -name \'*.c\' -exec sed -i "s/get_ds()/KERNEL_DS/g" {} \;
+
+diff --git a/src/wl/sys/wl_cfg80211_hybrid.c b/src/wl/sys/wl_cfg80211_hybrid.c
+index 7b606e0..51c81bc 100644
+--- a/src/wl/sys/wl_cfg80211_hybrid.c
++++ b/src/wl/sys/wl_cfg80211_hybrid.c
+@@ -450,7 +450,7 @@ wl_dev_ioctl(struct net_device *dev, u32 cmd, void *arg, u32 len)
+ ifr.ifr_data = (caddr_t)&ioc;
+
+ fs = get_fs();
+- set_fs(get_ds());
++ set_fs(KERNEL_DS);
+ #if defined(WL_USE_NETDEV_OPS)
+ err = dev->netdev_ops->ndo_do_ioctl(dev, &ifr, SIOCDEVPRIVATE);
+ #else
+diff --git a/src/wl/sys/wl_iw.c b/src/wl/sys/wl_iw.c
+index c4c610b..9c3c74e 100644
+--- a/src/wl/sys/wl_iw.c
++++ b/src/wl/sys/wl_iw.c
+@@ -117,7 +117,7 @@ dev_wlc_ioctl(
+ ifr.ifr_data = (caddr_t) &ioc;
+
+ fs = get_fs();
+- set_fs(get_ds());
++ set_fs(KERNEL_DS);
+ #if defined(WL_USE_NETDEV_OPS)
+ ret = dev->netdev_ops->ndo_do_ioctl(dev, &ifr, SIOCDEVPRIVATE);
+ #else