summaryrefslogtreecommitdiff
path: root/nongnu/packages/coq.scm
diff options
context:
space:
mode:
Diffstat (limited to 'nongnu/packages/coq.scm')
-rw-r--r--nongnu/packages/coq.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/nongnu/packages/coq.scm b/nongnu/packages/coq.scm
index 4c8b411..e8c9137 100644
--- a/nongnu/packages/coq.scm
+++ b/nongnu/packages/coq.scm
@@ -15,7 +15,7 @@
(define-public compcert
(package
(name "compcert")
- (version "3.11")
+ (version "3.12")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -24,7 +24,7 @@
(file-name (git-file-name name version))
(sha256
(base32
- "183b1fn7vhb9ykxax11x0bb2q6z5jnd874nzlxqnnm89j3ysr134"))))
+ "0pcrkz1as37iz2wcp8j226fjn672lrj0cip2s0wpkiy097qi0yc5"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -32,7 +32,7 @@
(add-before 'configure 'allow-newer-coq-version
(lambda _
(substitute* "configure"
- (("8.14.0") "8.16.0"))))
+ (("8.15.2") "8.16.1"))))
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
(let ((system ,(match (or (%current-target-system) (%current-system))