summaryrefslogtreecommitdiff
path: root/nongnu/packages/mesa.scm
diff options
context:
space:
mode:
Diffstat (limited to 'nongnu/packages/mesa.scm')
-rw-r--r--nongnu/packages/mesa.scm34
1 files changed, 21 insertions, 13 deletions
diff --git a/nongnu/packages/mesa.scm b/nongnu/packages/mesa.scm
index 8272715..293f09b 100644
--- a/nongnu/packages/mesa.scm
+++ b/nongnu/packages/mesa.scm
@@ -1,5 +1,22 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2013 Joshua Grant <tadni@riseup.net>
+;;; Copyright © 2014, 2016 David Thompson <davet@gnu.org>
+;;; Copyright © 2014, 2015, 2016, 2017 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2016 Nikita <nikita@n0.is>
+;;; Copyright © 2016, 2017, 2018, 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2017, 2018, 2019, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2017, 2018, 2019 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2020, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2020 Kei Kebreau <kkebreau@posteo.net>
+;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
+;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
+;;; Copyright © 2021, 2022, 2023 John Kehayias <john.kehayias@protonmail.com>
;;;
;;; This file is not part of GNU Guix.
;;;
@@ -55,7 +72,7 @@
(base32
"1zr0hi7k5s7my4q9hyj6ryzg89zyjx24zbqfv3c5rcq9pl87gc00"))))))
-;; Copied from (gnu packages gl) without changes, neede for mesa.
+;; Copied from (gnu packages gl) without changes, needed for mesa.
(define libva-without-mesa
;; Delay to work around circular import problem.
(delay
@@ -78,7 +95,7 @@
(define-public mesa-next
(package
(name "mesa")
- (version "22.2.1")
+ (version "22.3.2")
(source
(origin
(method url-fetch)
@@ -90,7 +107,7 @@
version "/mesa-" version ".tar.xz")))
(sha256
(base32
- "0g5ij57ljh3l04qf7qpildl45g5g7s8ycngc19z5xx1k1anbwy80"))))
+ "02ql6fawsxhzj21qzcyrzxnv28iwb6s8w8iagzjm6pvrm1cgfpf1"))))
(build-system meson-build-system)
(propagated-inputs
;; The following are in the Requires.private field of gl.pc.
@@ -237,15 +254,6 @@ svga,swrast,virgl")))
(("'lp_test_arit', ") ""))))
(_
'((display "No tests to disable on this architecture.\n"))))))
- ,@(if (string=? (%current-system) "i686-linux")
- '((add-after 'disable-failing-test 'fix-instrfromstring-test
- (lambda _
- ;; The instrfromstring test fails on i686, which has been already
- ;; fixed upstream but not in 22.2.1.
- ;; TODO: remove on update
- (substitute* "src/gallium/drivers/r600/sfn/sfn_instr_export.cpp"
- (("buf\\[6\\]") "buf[6] = {0}")))))
- '())
(add-before 'configure 'fix-dlopen-libnames
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))