summaryrefslogtreecommitdiff
path: root/nongnu/packages/messaging.scm
diff options
context:
space:
mode:
Diffstat (limited to 'nongnu/packages/messaging.scm')
-rw-r--r--nongnu/packages/messaging.scm94
1 files changed, 68 insertions, 26 deletions
diff --git a/nongnu/packages/messaging.scm b/nongnu/packages/messaging.scm
index edf120a..e03c35e 100644
--- a/nongnu/packages/messaging.scm
+++ b/nongnu/packages/messaging.scm
@@ -1,23 +1,7 @@
-;;; GNU Guix --- Functional package management for GNU
+;;; SPDX-License-Identifier: GPL-3.0-or-later
;;; Copyright © 2021, 2022 PantherX OS Team <team@pantherx.org>
-;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2022, 2023 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Evgenii Lepikhin <johnlepikhin@gmail.com>
-;;;
-;;; This file is not part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
(define-module (nongnu packages messaging)
#:use-module (gnu packages base)
@@ -31,10 +15,10 @@
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages kerberos)
#:use-module (gnu packages linux)
#:use-module (gnu packages nss)
#:use-module (gnu packages pulseaudio)
- #:use-module (gnu packages qt)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
@@ -50,7 +34,7 @@
(define-public element-desktop
(package
(name "element-desktop")
- (version "1.11.13")
+ (version "1.11.24")
(source
(origin
(method url-fetch)
@@ -59,7 +43,7 @@
"https://packages.riot.im/debian/pool/main/e/" name "/" name "_" version
"_amd64.deb"))
(sha256
- (base32 "04q2jwjykkch5giva1c6z6lljxqdw1i4xyh1bifmb4kybqmbrcnp"))))
+ (base32 "1bqhsimvchphjaha1vwj12xrrp8cy5bmvv1ha5nyifih8nk8k3l4"))))
(supported-systems '("x86_64-linux"))
(build-system binary-build-system)
(arguments
@@ -170,7 +154,7 @@ its core.")
(define-public signal-desktop
(package
(name "signal-desktop")
- (version "5.62.0")
+ (version "6.12.0")
(source
(origin
(method url-fetch)
@@ -179,7 +163,7 @@ its core.")
"https://updates.signal.org/desktop/apt/pool/main/s/" name "/" name "_" version
"_amd64.deb"))
(sha256
- (base32 "0q25wad9jwifvpbr6rvf58kpd2vibx80c9qmhflkz5iqjccp053s"))))
+ (base32 "16i8w1ba6y794c5xxv8rvk4vc7i598hiq4m9v4379rq40z3jn5cy"))))
(supported-systems '("x86_64-linux"))
(build-system binary-build-system)
(arguments
@@ -285,19 +269,21 @@ or iOS.")
(define-public zoom
(package
(name "zoom")
- (version "5.12.2.4816")
+ (version "5.13.11.1288")
(source
(origin
(method url-fetch)
(uri (string-append "https://cdn.zoom.us/prod/" version "/zoom_x86_64.tar.xz"))
(file-name (string-append name "-" version "-x86_64.tar.xz"))
(sha256
- (base32 "0vxlvxp0jzpc5xsh9wlxc74466i5ipg3fwpi0kv03rl8ib8y1n7p"))))
+ (base32 "1ngj15j9d7i0z4d0wraziyv75whp0digh8rg1jzfmi0ws3ir2d6b"))))
(supported-systems '("x86_64-linux"))
(build-system binary-build-system)
(arguments
(list #:validate-runpath? #f ; TODO: fails on wrapped binary and included other files
#:patchelf-plan
+ ;; Note: it seems like some (all?) of these only do anything in
+ ;; LD_LIBRARY_PATH, or at least needed there as well.
#~(let ((libs '("alsa-lib"
"at-spi2-atk"
"at-spi2-core"
@@ -337,6 +323,8 @@ or iOS.")
("lib/zoom/zoom"
,libs)
("lib/zoom/zopen"
+ ,libs)
+ ("lib/zoom/aomhost"
,libs)))
#:phases
#~(modify-phases %standard-phases
@@ -374,6 +362,49 @@ or iOS.")
,(list (string-append #$(this-package-input "nss") "/lib/nss")
#$@(map (lambda (pkg)
(file-append (this-package-input pkg) "/lib"))
+ ;; TODO: Reuse this long list as it is
+ ;; needed for aomhost. Or perhaps
+ ;; aomhost has a shorter needed list,
+ ;; but untested.
+ '("alsa-lib"
+ "atk"
+ "at-spi2-atk"
+ "at-spi2-core"
+ "cairo"
+ "cups"
+ "dbus"
+ "eudev"
+ "expat"
+ "gcc"
+ "glib"
+ "mesa"
+ "mit-krb5"
+ "nspr"
+ "libxcb"
+ "libxcomposite"
+ "libxdamage"
+ "libxext"
+ "libxkbcommon"
+ "libxkbfile"
+ "libxrandr"
+ "libxshmfence"
+ "pango"
+ "pulseaudio"
+ "xcb-util"
+ "xcb-util-wm"
+ "xcb-util-renderutil"
+ "zlib")))))
+ (wrap-program (string-append #$output "/lib/zoom/aomhost")
+ `("FONTCONFIG_PATH" ":" prefix
+ (,(string-join
+ (list
+ (string-append #$(this-package-input "fontconfig-minimal") "/etc/fonts")
+ #$output)
+ ":")))
+ `("LD_LIBRARY_PATH" prefix
+ ,(list (string-append #$(this-package-input "nss") "/lib/nss")
+ #$@(map (lambda (pkg)
+ (file-append (this-package-input pkg) "/lib"))
'("alsa-lib"
"atk"
"at-spi2-atk"
@@ -386,15 +417,21 @@ or iOS.")
"gcc"
"glib"
"mesa"
+ "mit-krb5"
"nspr"
+ "libxcb"
"libxcomposite"
"libxdamage"
+ "libxext"
"libxkbcommon"
"libxkbfile"
"libxrandr"
"libxshmfence"
"pango"
"pulseaudio"
+ "xcb-util"
+ "xcb-util-wm"
+ "xcb-util-renderutil"
"zlib")))))))
(add-after 'wrap-where-patchelf-does-not-work 'rename-binary
;; IPC (for single sign-on and handling links) fails if the
@@ -410,6 +447,8 @@ or iOS.")
(lambda _
(delete-file (string-append #$output "/environment-variables"))
(mkdir-p (string-append #$output "/bin"))
+ (symlink (string-append #$output "/lib/zoom/aomhost")
+ (string-append #$output "/bin/aomhost"))
(symlink (string-append #$output "/lib/zoom/zoom")
(string-append #$output "/bin/zoom"))
(symlink (string-append #$output "/lib/zoom/zopen")
@@ -468,13 +507,16 @@ or iOS.")
libxrender
libxshmfence
mesa
+ mit-krb5
nspr
nss
pango
pulseaudio
- qtmultimedia
+ xcb-util
xcb-util-image
xcb-util-keysyms
+ xcb-util-renderutil
+ xcb-util-wm
zlib))
(home-page "https://zoom.us/")
(synopsis "Video conference client")