summaryrefslogtreecommitdiff
path: root/nongnu/packages/patches
diff options
context:
space:
mode:
Diffstat (limited to 'nongnu/packages/patches')
-rw-r--r--nongnu/packages/patches/mono-mdoc-timestamping.patch15
-rw-r--r--nongnu/packages/patches/mono-pkgconfig-before-gac.patch65
2 files changed, 80 insertions, 0 deletions
diff --git a/nongnu/packages/patches/mono-mdoc-timestamping.patch b/nongnu/packages/patches/mono-mdoc-timestamping.patch
new file mode 100644
index 0000000..f7ae99a
--- /dev/null
+++ b/nongnu/packages/patches/mono-mdoc-timestamping.patch
@@ -0,0 +1,15 @@
+--- mono-4.4.1/external/api-doc-tools/monodoc/Monodoc/storage/ZipStorage.cs.orig 2018-11-26 22:16:25.008879747 +0100
++++ mono-4.4.1/external/api-doc-tools/monodoc/Monodoc/storage/ZipStorage.cs 2018-11-26 22:21:53.969770985 +0100
+@@ -74,6 +74,12 @@
+ id = GetNewCode ();
+
+ ZipEntry entry = new ZipEntry (id);
++ var SOURCE_DATE_EPOCH_string = Environment.GetEnvironmentVariable("SOURCE_DATE_EPOCH");
++ if (SOURCE_DATE_EPOCH_string != null)
++ {
++ var SOURCE_DATE_EPOCH = Convert.ToInt64(SOURCE_DATE_EPOCH_string);
++ entry.DateTime = new DateTime(SOURCE_DATE_EPOCH, DateTimeKind.Utc);
++ }
+ zipOutput.PutNextEntry (entry);
+ }
+
diff --git a/nongnu/packages/patches/mono-pkgconfig-before-gac.patch b/nongnu/packages/patches/mono-pkgconfig-before-gac.patch
new file mode 100644
index 0000000..7632d85
--- /dev/null
+++ b/nongnu/packages/patches/mono-pkgconfig-before-gac.patch
@@ -0,0 +1,65 @@
+diff -Naur mono-4.0.1.old/mcs/tools/xbuild/data/12.0/Microsoft.Common.targets mono-4.0.1/mcs/tools/xbuild/data/12.0/Microsoft.Common.targets
+--- mono-4.0.1.old/mcs/tools/xbuild/data/12.0/Microsoft.Common.targets 2015-04-24 02:26:18.000000000 +0100
++++ mono-4.0.1/mcs/tools/xbuild/data/12.0/Microsoft.Common.targets 2015-05-26 00:52:33.997847464 +0100
+@@ -229,8 +229,8 @@
+ $(ReferencePath);
+ @(AdditionalReferencePath);
+ {HintPathFromItem};
+- {TargetFrameworkDirectory};
+ {PkgConfig};
++ {TargetFrameworkDirectory};
+ {GAC};
+ {RawFileName};
+ $(OutDir)
+diff -Naur mono-4.0.1.old/mcs/tools/xbuild/data/14.0/Microsoft.Common.targets mono-4.0.1/mcs/tools/xbuild/data/14.0/Microsoft.Common.targets
+--- mono-4.0.1.old/mcs/tools/xbuild/data/14.0/Microsoft.Common.targets 2015-04-24 02:26:18.000000000 +0100
++++ mono-4.0.1/mcs/tools/xbuild/data/14.0/Microsoft.Common.targets 2015-05-26 00:52:41.832612748 +0100
+@@ -214,8 +214,8 @@
+ $(ReferencePath);
+ @(AdditionalReferencePath);
+ {HintPathFromItem};
+- {TargetFrameworkDirectory};
+ {PkgConfig};
++ {TargetFrameworkDirectory};
+ {GAC};
+ {RawFileName};
+ $(OutDir)
+diff -Naur mono-4.0.1.old/mcs/tools/xbuild/data/2.0/Microsoft.Common.targets mono-4.0.1/mcs/tools/xbuild/data/2.0/Microsoft.Common.targets
+--- mono-4.0.1.old/mcs/tools/xbuild/data/2.0/Microsoft.Common.targets 2015-04-24 02:26:18.000000000 +0100
++++ mono-4.0.1/mcs/tools/xbuild/data/2.0/Microsoft.Common.targets 2015-05-26 00:52:46.298478961 +0100
+@@ -139,8 +139,8 @@
+ $(ReferencePath);
+ @(AdditionalReferencePath);
+ {HintPathFromItem};
+- {TargetFrameworkDirectory};
+ {PkgConfig};
++ {TargetFrameworkDirectory};
+ {GAC};
+ {RawFileName};
+ $(OutDir)
+diff -Naur mono-4.0.1.old/mcs/tools/xbuild/data/3.5/Microsoft.Common.targets mono-4.0.1/mcs/tools/xbuild/data/3.5/Microsoft.Common.targets
+--- mono-4.0.1.old/mcs/tools/xbuild/data/3.5/Microsoft.Common.targets 2015-04-24 02:26:18.000000000 +0100
++++ mono-4.0.1/mcs/tools/xbuild/data/3.5/Microsoft.Common.targets 2015-05-26 00:52:52.119304583 +0100
+@@ -167,8 +167,8 @@
+ $(ReferencePath);
+ @(AdditionalReferencePath);
+ {HintPathFromItem};
+- {TargetFrameworkDirectory};
+ {PkgConfig};
++ {TargetFrameworkDirectory};
+ {GAC};
+ {RawFileName};
+ $(OutDir)
+diff -Naur mono-4.0.1.old/mcs/tools/xbuild/data/4.0/Microsoft.Common.targets mono-4.0.1/mcs/tools/xbuild/data/4.0/Microsoft.Common.targets
+--- mono-4.0.1.old/mcs/tools/xbuild/data/4.0/Microsoft.Common.targets 2015-04-24 02:26:18.000000000 +0100
++++ mono-4.0.1/mcs/tools/xbuild/data/4.0/Microsoft.Common.targets 2015-05-26 00:52:56.519172776 +0100
+@@ -229,8 +229,8 @@
+ $(ReferencePath);
+ @(AdditionalReferencePath);
+ {HintPathFromItem};
+- {TargetFrameworkDirectory};
+ {PkgConfig};
++ {TargetFrameworkDirectory};
+ {GAC};
+ {RawFileName};
+ $(OutDir)