summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2023-03-12 19:42:56 +0100
committerVivien Kraus <vivien@planete-kraus.eu>2023-03-12 20:37:30 +0100
commit45e742faadcc007cc06217ab3e04333dabc285b5 (patch)
treecbe70e817aea69e3a24e9946c428d46569cf0918 /configure.ac
parent258d8d016f4b1dca38cf2d03b7faa0cb09f5496f (diff)
Remember the window dimensions with Gsettings.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9250f3a..aca35a1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,6 +21,7 @@ glprog_INIT
AM_PROG_VALAC
AM_MISSING_PROG([GLIB_COMPILE_RESOURCES], [glib-compile-resources])
AM_MISSING_PROG([CONVERT], [convert])
+GLIB_GSETTINGS
# Checks for libraries.
AM_GNU_GETTEXT([external])
@@ -67,10 +68,14 @@ AM_CONDITIONAL([SHLIBS_IN_BINDIR], [test "x$i_am_windows" = "xyes"])
case "$VERSION" in
*-*)
AC_SUBST([DISFLUID_IS_NIGHTLY], [yes])
+ AC_SUBST([DISFLUID_NIGHTLY_SUFFIX], [.Devel])
+ AC_SUBST([DISFLUID_NIGHTLY_SUFFIX_SLASH], [/Devel])
AC_DEFINE([DISFLUID_IS_NIGHTLY], [1], [Whether disfluid is built from a snapshot, as opposed to an official release.])
;;
*)
AC_SUBST([DISFLUID_IS_NIGHTLY], [no])
+ AC_SUBST([DISFLUID_NIGHTLY_SUFFIX], [])
+ AC_SUBST([DISFLUID_NIGHTLY_SUFFIX_SLASH], [])
AC_DEFINE([DISFLUID_IS_NIGHTLY], [0], [Whether disfluid is built from a snapshot, as opposed to an official release.])
;;
esac
@@ -81,5 +86,6 @@ AC_CONFIG_FILES([
Makefile
lib/Makefile libprog/Makefile
po/Makefile.in
- tests/libgnu/Makefile tests/libprog/Makefile])
+ tests/libgnu/Makefile tests/libprog/Makefile
+ settings/eu.planete_kraus.Disfluid.gschema.xml])
AC_OUTPUT