summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-24 20:09:00 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-24 20:09:00 +0200
commite4ad2f178af65be6c8ca6e98a667787674cd8c82 (patch)
tree0097ac135d7f3fe81d33518ce1ce856583adcd07
parent463d2995e64aa7160180e91fba61ae53633c8065 (diff)
gnu: python-urllib3: Update to 2.2.1.python-team
* gnu/packages/python-web.scm (python-urllib3): Update to 2.2.1. Re-indent. [build-system]: Use PYPROJECT-BUILD-SYSTEM. [native-inputs]: Add PYTHON-HATCHLING. Change-Id: I980c0cad01b39cce44e3cae09e776fbdff9b162a
-rw-r--r--gnu/packages/python-web.scm41
1 files changed, 21 insertions, 20 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 04f98b8a4d..e8ead0ef12 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3999,30 +3999,31 @@ addon for removing tracking fields from URLs.")
(define-public python-urllib3
(package
(name "python-urllib3")
- (version "1.26.15")
+ (version "2.2.1")
(source
- (origin
- (method url-fetch)
- (uri (pypi-uri "urllib3" version))
- (sha256
- (base32
- "01dkqv0rsjqyw4wrp6yj8h3bcnl7c678qkj845596vs7p4bqff4a"))))
- (build-system python-build-system)
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "urllib3" version))
+ (sha256
+ (base32
+ "06fg8jj64lgxr2jrizzrsdvaf1avpg5qmhvnswhfbf8sqrv0hmyh"))))
+ (build-system pyproject-build-system)
(arguments `(#:tests? #f))
+ (native-inputs (list python-hatchling))
(propagated-inputs
(append
- ;; These 5 inputs are used to build urrlib3[secure]
- (list python-certifi)
- (if (member (%current-system)
- (package-transitive-supported-systems python-cryptography))
- (list python-cryptography)
- '())
- (list python-idna)
- (if (member (%current-system)
- (package-transitive-supported-systems python-pyopenssl))
- (list python-pyopenssl)
- '())
- (list python-pysocks)))
+ ;; These 5 inputs are used to build urrlib3[secure]
+ (list python-certifi)
+ (if (member (%current-system)
+ (package-transitive-supported-systems python-cryptography))
+ (list python-cryptography)
+ '())
+ (list python-idna)
+ (if (member (%current-system)
+ (package-transitive-supported-systems python-pyopenssl))
+ (list python-pyopenssl)
+ '())
+ (list python-pysocks)))
(home-page "https://urllib3.readthedocs.io/")
(synopsis "HTTP library with thread-safe connection pooling")
(description