summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Volf <~@wolfsden.cz>2024-05-14 18:13:23 +0200
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2024-05-14 19:02:50 +0200
commitd1609e765bb48d1a5302ed0df4f1ed300a571eff (patch)
tree48662d8cb7b736c5e4714823370e3ab9e51ef716
parent81d5098e9b7667814d9d62ad545ad9168e6baa23 (diff)
nongnu: firefox: Update to 126.0 [security fixes].
Fixes CVE-2024-4367, CVE-2024-4764, CVE-2024-4765, CVE-2024-4766, CVE-2024-4767, CVE-2024-4768, CVE-2024-4769, CVE-2024-4770, CVE-2024-4771, CVE-2024-4772, CVE-2024-4773, CVE-2024-4774, CVE-2024-4775, CVE-2024-4776, CVE-2024-4777, CVE-2024-4778. * nongnu/packages/mozilla.scm (firefox): Update to 126.0. Signed-off-by: Jonathan Brielmaier <jonathan.brielmaier@web.de>
-rw-r--r--nongnu/packages/mozilla.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/nongnu/packages/mozilla.scm b/nongnu/packages/mozilla.scm
index 7807894..b6fdec9 100644
--- a/nongnu/packages/mozilla.scm
+++ b/nongnu/packages/mozilla.scm
@@ -532,20 +532,20 @@ MOZ_ENABLE_WAYLAND=1 exec ~a $@\n"
;; Update this id with every firefox update to its release date.
;; It's used for cache validation and therefore can lead to strange bugs.
-(define %firefox-build-id "20240429124342")
+(define %firefox-build-id "20240513130807")
(define-public firefox
(package
(inherit firefox-esr)
(name "firefox")
- (version "125.0.3")
+ (version "126.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://archive.mozilla.org/pub/firefox/releases/"
version "/source/firefox-" version ".source.tar.xz"))
(sha256
- (base32 "05jnpnc0qym08f7rlapjm36g729445k3nba2rvf4a0sabsw6c726"))))
+ (base32 "09l5hsyrkimmkd7wbhnamy5mwmwwxjfa742hpkjjkhlyk6hq43li"))))
(arguments
(substitute-keyword-arguments (package-arguments firefox-esr)
((#:phases phases)