summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am21
1 files changed, 4 insertions, 17 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5bd97d6..7925ce8 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -5,25 +5,12 @@ RELOCATABLE_LIBRARY_PATH = $(libdir)
include %D%/libdisfluid/Makefile.am
include %D%/gobject/Makefile.am
+include %D%/gir/Makefile.am
include %D%/vala/Makefile.am
DISTCLEANFILES += $(defexec_DATA)
-EXTRA_DIST += %D%/introspection-files %D%/introspection-libraries
+.PHONY: update-introspected-libs
-if BUILD_GOBJECT
-
-%D%/introspection-files: $(INTROSPECTION_LISTS) $(INTROSPECTION_SRC)
- $(AM_V_GEN) (for src in $(INTROSPECTED_FILES) ; do echo "$$src" ; done) > %D%/introspection-files-t && mv %D%/introspection-files-t $(srcdir)/%D%/introspection-files
-
-%D%/introspection-libraries: $(INTROSPECTION_LISTS) $(INTROSPECTION_SRC)
- $(AM_V_GEN) (for lib in $(INTROSPECTED_LIBS) ; do echo "$$lib" ; done) > %D%/introspection-libraries-t && mv %D%/introspection-libraries-t %D%/introspection-libraries
-
-else # not BUILD_GOBJECT
-
-%D%/introspection-files: $(INTROSPECTION_LISTS) $(INTROSPECTION_SRC)
- @(>&2 echo "The introspected files have changed, but gobject compilation is disabled." ; exit 1)
-%D%/introspection-libraries: $(INTROSPECTION_LISTS) $(INTROSPECTION_SRC)
- @(>&2 echo "The introspected files have changed, but gobject compilation is disabled." ; exit 1)
-
-endif # not BUILD_GOBJECT
+update-introspected-libs: $(INTROSPECTED_LIBS)
+ @true