summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2019-03-09 16:48:21 -0500
committerDavid Thompson <dthompson2@worcester.edu>2019-03-09 18:00:28 -0500
commit8b6b0e48362753b45b034394021119e88ac95131 (patch)
tree06fafeee9b7de319c3f6c25d6c3d211925b781f7
parent2b613a1a5d4d41b0b5d1f6ea7254585be0c209fa (diff)
Take another stab at this whole guix deploy thing.wip-deploy2
-rw-r--r--Makefile.am1
-rw-r--r--gnu/local.mk3
-rw-r--r--gnu/machine.scm59
-rw-r--r--guix/scripts/deploy.scm76
4 files changed, 138 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index cf35770ba7..4a7bfe2ba6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -250,6 +250,7 @@ MODULES = \
guix/scripts/weather.scm \
guix/scripts/container.scm \
guix/scripts/container/exec.scm \
+ guix/scripts/deploy.scm \
guix.scm \
$(GNU_SYSTEM_MODULES)
diff --git a/gnu/local.mk b/gnu/local.mk
index 63857d98a8..e0b3c19f35 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -545,6 +545,7 @@ GNU_SYSTEM_MODULES = \
%D%/system/shadow.scm \
%D%/system/uuid.scm \
%D%/system/vm.scm \
+ %D%/machine.scm \
\
%D%/build/accounts.scm \
%D%/build/activation.scm \
@@ -611,7 +612,7 @@ GNU_SYSTEM_MODULES += \
%D%/installer/newt/user.scm \
%D%/installer/newt/utils.scm \
%D%/installer/newt/welcome.scm \
- %D%/installer/newt/wifi.scm
+ %D%/installer/newt/wifi.scm
installerdir = $(guilemoduledir)/%D%/installer
dist_installer_DATA = \
diff --git a/gnu/machine.scm b/gnu/machine.scm
new file mode 100644
index 0000000000..4fde7d5c01
--- /dev/null
+++ b/gnu/machine.scm
@@ -0,0 +1,59 @@
+(define-module (gnu machine)
+ #:use-module ((gnu packages package-management) #:select (guix))
+ #:use-module (gnu system)
+ #:use-module (guix derivations)
+ #:use-module (guix inferior)
+ #:use-module (guix packages)
+ #:use-module (guix ssh)
+ #:use-module (guix store)
+ #:use-module (oop goops)
+ #:use-module (ssh session)
+ #:export (<machine>
+ system
+ display-name
+ build-os
+ deploy-os
+ remote-eval
+
+ <sshable-machine>
+ host-name
+ ssh-port
+ ssh-user))
+
+(define-class <machine> ()
+ (system #:getter system #:init-keyword #:system))
+
+(define-method (display-name (machine <machine>))
+ (operating-system-host-name (system machine)))
+
+(define-method (build-os (machine <machine>) store)
+ (let* ((guixdrv (run-with-store store (package->derivation guix)))
+ (guixdir (and (build-derivations store (list guixdrv))
+ (derivation->output-path guixdrv)))
+ (osdrv (run-with-store store (operating-system-derivation
+ (system machine)))))
+ (and (build-derivations store (list osdrv))
+ (list (derivation-file-name osdrv)
+ (derivation->output-path osdrv)))))
+
+(define-method (deploy-os (machine <machine>) store osdrv)
+ (error "not implemented"))
+
+(define-method (remote-eval (machine <machine>) exp)
+ (error "not implemented"))
+
+(define-class <sshable-machine> (<machine>)
+ (host-name #:getter host-name #:init-keyword #:host-name)
+ (ssh-port #:getter ssh-port #:init-keyword #:ssh-port #:init-form 22)
+ (ssh-user #:getter ssh-user #:init-keyword #:ssh-user #:init-form "root")
+ ;; ??? - SSH key config?
+ )
+
+(define-method (deploy-os (machine <sshable-machine>) store osdrvs)
+ (let ((session (open-ssh-session (host-name machine)
+ #:user (ssh-user machine)
+ #:port (ssh-port machine))))
+ (with-store store (send-files store osdrvs
+ (connect-to-remote-daemon session)
+ #:recursive? #t))
+ #t))
diff --git a/guix/scripts/deploy.scm b/guix/scripts/deploy.scm
new file mode 100644
index 0000000000..bcb3a2ea4c
--- /dev/null
+++ b/guix/scripts/deploy.scm
@@ -0,0 +1,76 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 David Thompson <davet@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (guix scripts deploy)
+ #:use-module (gnu machine)
+ #:use-module (guix ui)
+ #:use-module (guix scripts)
+ #:use-module (guix scripts build)
+ #:use-module (guix store)
+ #:use-module (ice-9 format)
+ #:use-module (srfi srfi-1)
+ #:use-module (srfi srfi-37)
+ #:export (guix-deploy))
+
+(define (show-help)
+ (display (G_ "Usage: guix deploy WHATEVER\n")))
+
+(define %options
+ (cons* (option '(#\h "help") #f #f
+ (lambda args
+ (show-help)
+ (exit 0)))
+ %standard-build-options))
+
+(define %default-options
+ '((system . ,(%current-system))
+ (substitutes? . #t)
+ (build-hook? . #t)
+ (graft? . #t)
+ (print-build-trace? . #t)
+ (print-extended-build-trace? . #t)
+ (multiplexed-build-output? . #t)
+ (debug . 0)
+ (verbosity . 2)))
+
+(define (load-source-file file)
+ (let ((module (make-user-module '())))
+ (load* file module)))
+
+(define (guix-deploy . args)
+ (define (handle-argument arg result)
+ (alist-cons 'file arg result))
+ (let* ((opts (parse-command-line args %options (list %default-options)
+ #:argument-handler handle-argument))
+ (file (assq-ref opts 'file))
+ (machines (load-source-file file)))
+ (with-store store
+ (set-build-options-from-command-line store opts)
+ ;; Build all the OSes and create a mapping from machine to OS derivation
+ ;; for use in the deploy step.
+ (let ((osdrvs (map (lambda (machine)
+ (format #t "building ~a... " (display-name machine))
+ (let ((osdrv (build-os machine store)))
+ (display "done\n")
+ (cons machine osdrv)))
+ machines)))
+ (for-each (lambda (machine)
+ (format #t "deploying to ~a... " (display-name machine))
+ (deploy-os machine store (assq-ref osdrvs machine))
+ (display "done\n"))
+ machines)))))