summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-28 21:18:35 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-15 23:33:12 +0000
commit024a0e2288e561a2d4f6ce11437917e2c31e1101 (patch)
tree65765448b182d6b8e9d530104d5a258d27594424
parentf59f85bdeb1b12225e2a5e4bc3085ab5ff3d70eb (diff)
gnu: Add go-github-com-blang-semver-v4.
* gnu/packages/golang-xyz.scm (go-github-com-blang-semver-v4): New variable. Change-Id: I87132b1b727b7e6ef4d46bb08dc5ad509db4e2e4
-rw-r--r--gnu/packages/golang-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 425a6f15af..2b0aa97f99 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -306,6 +306,31 @@ information and periodically output metrics")
"Semver is a library for Semantic versioning written in Go.")
(license license:expat)))
+(define-public go-github-com-blang-semver-v4
+ (package
+ (inherit go-github-com-blang-semver)
+ (name "go-github-com-blang-semver-v4")
+ (version "4.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/blang/semver")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "14h9ys4n4kx9cbj42lkdf4i5k3nkll6sd62jcvl7cs565v6fiknz"))))
+ (arguments
+ (list
+ #:import-path "github.com/blang/semver/v4"
+ #:unpack-path "github.com/blang/semver"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-examples
+ (lambda* (#:key import-path #:allow-other-keys)
+ (delete-file-recursively
+ (string-append "src/" import-path "/examples")))))))))
+
(define-public go-github-com-bmizerany-perks-quantile
(package
(name "go-github-com-bmizerany-perks-quantile")