summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-06-21 12:02:01 +0200
committerJulien Lepiller <julien@lepiller.eu>2021-08-08 22:30:56 +0200
commit03f05b475badce7440448e6b1bc60e2e51e885b6 (patch)
tree84ed89cf1cb0fbe50de1caae54f7332e84a19753
parent2787bcbd1bbfc01516d28914edf1697aa3740237 (diff)
gnu: Add ocaml-fix.
* gnu/packages/ocaml.scm (ocaml-fix): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
-rw-r--r--gnu/packages/ocaml.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 2e879eb40d..92c00801a4 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7062,6 +7062,30 @@ structure and it can process text without a complete in-memory
representation.")
(license license:isc)))
+(define-public ocaml-fix
+ (package
+ (name "ocaml-fix")
+ (version "20201120")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.inria.fr/fpottier/fix")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1j40mg1gy03c0djzx3nzmpvnl984s14n04zwcmp2xnlidq48kvs4"))))
+ (build-system dune-build-system)
+ (arguments
+ ;; No tests.
+ '(#:tests? #f))
+ (home-page "https://gitlab.inria.fr/fpottier/fix")
+ (synopsis "Facilities for memoization and fixed points")
+ (description "This package provides helpers with various constructions
+that involve memoization and recursion.")
+ (license license:lgpl2.0)))
+
(define-public ocaml-bigstringaf
(package
(name "ocaml-bigstringaf")