summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:28:00 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:51 +0200
commit04e7983502e54916161641315ac26581ed86e912 (patch)
treec58f69b7fc99045c0cfe7ee32cc79085fb77e4d0
parentbebd522580fdb187c18eaa645ed4105756aa193d (diff)
gnu: Add texlive-texlogsieve.
* gnu/packages/tex.scm (texlive-texlogsieve): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d1da411b62..e64048dcab 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6528,6 +6528,29 @@ references/citations warnings. It's also possible to add custom filter
patterns.")
(license license:lppl1.3+)))
+(define-public texlive-texlogsieve
+ (package
+ (name "texlive-texlogsieve")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/man/man1/texlogsieve.1"
+ "doc/man/man1/texlogsieve.man1.pdf"
+ "doc/support/texlogsieve/"
+ "scripts/texlogsieve/")
+ (base32
+ "0pssh34f2263qfpirmv1np9ncjw9d9zyjqbxpin12px2hmvjvip6")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "texlogsieve")))
+ (home-page "https://ctan.org/pkg/texlogsieve")
+ (synopsis "Filter and summarize LaTeX log files")
+ (description
+ "@command{texlogsieve} reads a LaTeX log file (or the standard input if
+no file is specified), filters out less relevant messages, and displays
+a summary report.")
+ (license license:gpl3+)))
+
(define-public texlive-ticollege
(package
(name "texlive-ticollege")