summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-09-26 20:21:35 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-02 10:54:40 +0000
commit061187f670056f48b6f88aa3d539378c16cca27b (patch)
treed8df1f375592e4438cc1351c40a2f938d5b4eedd
parentc6843609bde8ce592ca18e2dbecfa577525153e8 (diff)
gnu: gnome-dictionary: Update to 40.0.
* gnu/packages/gnome.scm (gnome-dictionary): Update to 40.0. [source]: Fix the URI. [arguments]: Wrap it and remove a trailing #t. Replace the 'patch-install-script phase by a new 'skip-gtk-update-icon-cache phase.
-rw-r--r--gnu/packages/gnome.scm25
1 files changed, 12 insertions, 13 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 0732c8151d..ffb2146e17 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9671,26 +9671,25 @@ fit the GNOME desktop.")
(define-public gnome-dictionary
(package
(name "gnome-dictionary")
- (version "3.26.1")
+ (version "40.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
- (version-major+minor version) "/"
+ (version-major version) "/"
name "-" version ".tar.xz"))
(sha256
(base32
- "007k2bq8iplg4psdpz074r5d4zxvn4s95qym4rw9hs6giljbrf0n"))))
+ "1d8dhcfys788vv27v34i3s3x3jdvdi2kqn2a5p8c937a9hm0qr9f"))))
(build-system meson-build-system)
- (arguments '(#:glib-or-gtk? #t
- #:phases (modify-phases %standard-phases
- (add-after 'unpack 'patch-install-script
- (lambda _
- ;; This script attempts to compile glib schemas
- ;; and create an empty MIME database. We do
- ;; that elsewhere, so prevent it from running.
- (substitute* "build-aux/post-install.sh"
- (("\\[ -z \"\\$DESTDIR\" \\]") "false"))
- #t)))))
+ (arguments
+ '(#:glib-or-gtk? #t
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ ;; Don't create 'icon-theme.cache'.
+ (lambda _
+ (substitute* "build-aux/meson/post-install.py"
+ (("gtk-update-icon-cache") "true")))))))
(native-inputs
`(("glib:bin" ,glib "bin")
("gobject-introspection" ,gobject-introspection)